Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решите задачу по информатике. Дано натуральное число, определить количество цифр в этом числе. На языке Pascal

10-11 класс

ANRICO 02 дек. 2013 г., 21:06:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ulya912
02 дек. 2013 г., 22:12:35 (10 лет назад)

var
  i: integer;
  
begin
  readln(i);
  writeln(length(inttostr(i)));
end.

Ответить

Другие вопросы из категории

Записать с помощью стандартного приложения "Звукозапись" звук длительностью 1 минута с частотой дискретизации 22, 050 КГц и глубиной кодирования 8

битов(моно), а затем тот же самый звук с частотой дискретизации 44, 1 КГц и глубиной кодирования 16 битов(моно). Сравнить объемы полученных файлов.

Читайте также

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3



Вы находитесь на странице вопроса "Решите задачу по информатике. Дано натуральное число, определить количество цифр в этом числе. На языке Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.