Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

10-11 класс

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

Notizka 25 апр. 2014 г., 15:37:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
788876геккибютпр
25 апр. 2014 г., 17:42:13 (10 лет назад)

вот программа 1задачи на C++, только возможности её скомпилировать не было:(

#include <iostream>
#include <conio.h>
#include <stdio.h>
using namespace std;
main()
{   
setlocale(0, "");   
double m;   
double k;   
srand(time(NULL));        
printf("Первое случайное число\n");     
m = rand() % 1000;     
cout << m << endl;     
getch();     
printf("Второе случайное число\n");       
k = rand() % 1000;     
cout << k << endl;     
getch();
printf("Сумма:%d",m+k);
printf("\nРазность:%d",m-k);
printf("\nПроизведение:%d",m*k);
printf("\nЧастное:%d",m/k);
getch(); 
}



А это та же, только на паскале:

program fofgogjoj;
var
a,b:real;
begin
a:=random(1000);
b:=random(1000);
Writeln('Первое случайное число равно: ',a);
Writeln('Второе случайное число равно: ',b);
Writeln;
Writeln('Сумма: ',a+b);
Writeln('Разность: ',a-b);
Writeln('Произведение: ',a*b);
Writeln('Частное: ', a/b:0:2);
end.

Ответить

Другие вопросы из категории

решите в еxel .

//////////////
2x +y +34z = 1 внизу

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

Вася передает Пете сообщение, состоящее только из символов ( заглавных и строчных) латинского алфавита, пробелов и знаков препинания (. , ! ?) за 2

минуты. Сообщение состоит из 200 символов. Какова скорость передачи информации (бит в секунду) ?

Читайте также

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество

элементов всех нечетных элементов массива которые делятся на 3

на языке Pascal желательно

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

напишите программу ,которая

запрашивает значения четырех переменных (A,B,C,D) типа integer и выводит их сумму. ввод первой пары значений (A,B) произведите на одной строке ,ввод другой пары. (C,D) ; на другой строке. Результат выведите на отдельную строку и курсор оставьте на той же строке. Эту рограмму надо написать на языке pascal



Вы находитесь на странице вопроса "Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.