Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составить программу, которая генерирует 10 случайных чисел в диапазоне от -20 до 30,выводит эти числа на экран и вычисляет сумму отрицательных

10-11 класс

Outlaw32 25 февр. 2015 г., 20:42:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anyaosi777
25 февр. 2015 г., 22:44:10 (9 лет назад)

var a:array[1..10] of integer;
i,s:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(51)-20; write(a[i],' '); end;
writeln;
s:=0;
for i:=1 to 10 do
if a[i]<0 then s:= s+a[i];
writeln('Сумма отрицательных чисел равна ', s);
end.

Ответить

Другие вопросы из категории

(код паскаль)Написать набор процедур для работы с обыкновенными дробями, обеспечив их сложение, вычитание, умножение, деление. Примечание: обыкновенную

дробь представлять двумя целыми числами: первое число представляет числитель дроби, а второе - знаменатель. В процессе вычислений требуется сокращать дроби на их наибольший общий делитель (НОД). Если одно из чисел равно нулю, то НОД берем равным 1. Разработать также отдельные процедуры для ввода (на экран выводится надпись: «Введите числитель и знаменатель обыкновенной дроби») и вывода обыкновенных дробей (a/b).

Помогите ,пожалуйста,составить блок-схему. Program qqq; Var a:array[0…9] of byte; n,k: integer; j: byte; begin readln(n); for j:=0 to 9 do a[j]:=0;

while n>0 do begin k:=n mod 10; n:=n div 10; inc (a[k]); end; for j:=0 to 9 do if a[j].0 then writeln (j, a[j]); for j:=0 to 9 do if a[j]=0 then writeln(j); end.

Читайте также

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Пожалуйста помогите! Завтра у меня экзамен.. И вот вопрос, "Составить приложение в котором, создать массив целых чисел в интервале от -50 до 50 количестве

30 элементов. Заполнить с помощью случайных чисел, вычислить сумму отрицательных чисел и количество положительных чисел. Заранее спасибо!

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Составить программу, которая генерирует 10 случайных чисел в диапазоне от -20 до 30,выводит эти числа на экран и вычисляет сумму отрицательных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.