Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

10-11 класс

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)

Svitanok2008 27 марта 2014 г., 8:37:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slavenchik
27 марта 2014 г., 10:14:39 (10 лет назад)

        [STAThread]
        static void Main()
        {
            int N = Int32.Parse(Console.ReadLine());
            for (int i = 1; i <= N; i++)
                for (int j = 1; j <= N; j++)
                    if (isFriendly(i, j))
                        Console.WriteLine("{0} {1," + N.ToString().Length + "}", i, j, N.ToString().Length);
            Console.ReadKey(false);
        }
        static bool isFriendly(int a, int b)
        {
            int Sum = 0;
            for (int i = 1; i < a; i++)
            {
                if (a  i == 0)
                    Sum += i;
            }
            if (Sum != b)
                return false;
            else
            {
                Sum = 0;
                for (int i = 1; i < b; i++)
                {
                    if (b  i == 0)
                        Sum += i;
                }
                return Sum == a;
            }
        }
    }
}

Ответить

Другие вопросы из категории

Вася передает Пете сообщение, состоящее только из символов ( заглавных и строчных) латинского алфавита, пробелов и знаков препинания (. , ! ?) за 2

минуты. Сообщение состоит из 200 символов. Какова скорость передачи информации (бит в секунду) ?

Дано натуральное число N. Выяснить, сколько положительных

элементов содержит матрица [Аij]i=1,...,n;i,j=1,....,n, если Аi.j =cos(i^2 +n).

Читайте также

Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в К- ю степень( где К- количество цифр в числе) равна самому числу.

Например, 153=1³ + 5³ + 3³.
Входная строка содержит два натуральных числа- значения а и б.
Входные данные
Входная строка содержит два натуральных числа - значения а и б, разделенных пробелами. Гарантируется, что а≥б.
Выходные данные
Программа должна вывести в одну строчку все числа Армстронга на отрезке а, б, разделив их пробелами. если таких чисел нет, программа должна вывести -1.

Катя, Наташа, Римма и Лиля – студентки факультета иностранных языков – увлекаются музыкой и каждая из них играет на каком-нибудь инструменте, но только на

одном: гитаре, скрипке, арфе или фортепиано.

Каждая из них учится на одном из отделений факультета: английского, французского, немецкого или испанского языка.

Та из них, которая играет на гитаре, учится на отделении испанского языка. Наташа не играет ни на скрипке, ни на арфе, и не учится на отделении английского языка. Катя тоже не играет ни на арфе, ни на скрипке и не учится на отделении английского языка. Студентка отделения немецкого языка не играет на арфе. А Римма учится на отделении французского языка и не играет на скрипке.

На каком инструменте играет и на каком отделении факультета иностранных языков учится каждая из студенток?

получается лилия играет на скрипке и не играется на гитаре, не учится на французском.

рима на французском но не играет на скрипке

наташа не на англйским и не играет не на скрипке не на арфе

катя не на английском не на скрипке не на арфе

У исполнителя Альфа две команды, которым присвоены номера:1. прибавь 12. умножь на b(b – неизвестное натуральное число; b ≥ 2)Выполняя первую из них,

Альфа увеличивает число на экране на 1, авыполняя вторую, умножает это число на b .Программа для исполнителя Альфа – это последовательность номеровкоманд.Известно, что программа 11211 переводит число 6 в двузначное число.Определите наибольшее возможное значение b .

решите задачу.турист идет к озеру. у развилки дороги сидят 2 брата и каждый из них знает,какая дорога ведет к озеру.. на вопросы братья

отвечают только да и нет. один из них всегда говорит правду. другой всегда лжет. все это знает турист. помогите туристу сформулировать такие вопросы чтобы узнать, какая дорога ведет к озеру;

1) 2 вопроса одному из братьев;

2) 1 вопрос одному из братьев.



Вы находитесь на странице вопроса "Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.