Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Привет,помогите составить программу и блок-схему по массивам "В заданном массиве найти сумму всех элементов,удовлетворяющих неравенству

10-11 класс

10<=а(i)<=20.Вывести исходный массив и результат"

555355 12 июля 2014 г., 18:04:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
FUKemail
12 июля 2014 г., 20:45:38 (9 лет назад)

uses crt;
var a:array[1..100] of real;
i,n:integer; s:real;
begin
clrscr;

s:=0;
randomize;
write('vvedite kol-vo elementov:');
read(n);
for i:=1 to n do
begin
a[i]:=random(100)-50;
if (a[i]>=10) and (a[i]<=20) then s:=s+a[i];
end;
write('s=',s);
end.

Ответить

Другие вопросы из категории

На логику. Помогите пожалуйста.

10 кл
срочно нужно

1)Сколько бит информации несет сообщение: "Пойманная в пруду рыба - щука", если всего в пруду 256 карасей, 40 щук, и 104 карпа?

2)В таксопарке 10 автомобилей "Волга", 7 автомобилей "Лада" и 8 автомобилей "Вольво". Сколько информации несет сообщение о марке автомобиля?

3)Была получена телеграмма: "Встречайте, вагон 7". Известно, что в составе поезда 16 вагонов. Какое количество Информации было получено

Ребята нужно с решением, прошу вас помогите бро.

Дано

вещественное число цена 1 кг конфет. Вывести стоимость 1, 2, ., 10 кг конфет.

Читайте также

Помогите составить программу для вычисления значения функции y для заданного значения x

у= если x<-3 то
y= √1 - x²
если 1,5<x-3, то
y= в числителе 1 в знаменателе модуль x +2
если x>1,5, то
y=tg x
Составить словесное описание алгоритма, составить блок схему, описать используемые элементы

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

Написать программу (в Pascal) и составить блок-схему по задаче: В двумерном массиве произвольной размеренности подсчитать количество элементов, равных

наибольшему элементу в этом массиве. Вывести значение наибольшего элемента.



Вы находитесь на странице вопроса "Привет,помогите составить программу и блок-схему по массивам "В заданном массиве найти сумму всех элементов,удовлетворяющих неравенству", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.