Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

требуется найти сумму цифр числа( 5.....5)²,где 0< n<19000. Составьте программу.

5-9 класс

Danio122002 13 апр. 2015 г., 1:28:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1986DAVO
13 апр. 2015 г., 2:50:56 (9 лет назад)

Стал ещё сильнее уважать свой ноут:)

uses

  System.Numerics;

var
  k, m: BigInteger;
  n, j: word;

begin
  readln(n);
  for j := 1 to n do
    k := k * 10 + 5;
  k := k * k;
  writeln(n, ' ', k);

  repeat
    m := m + (k mod 10);
    k := k div 10;
  until (BigInteger.Parse(k.toString()).isZero); //нет, isZero просто так не принимает IDE

  k := 0;
  writeln('Sum: ', m);
end.

Ответить

Читайте также

PascalABC выдает ошибку,где она?!(Сама задача:Дано двузначное число. Найти сумму и произведение его цифр)

Var a,b,c:integer;
Begin
Readln(a);
b:= a div 10;
c:= a mod 10;
writeln('сумма цифр числа',a,'равна',b+c,'произведение равно'b*c)
end.

Введите целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1234
Сумма цифр числа 1234 равна 10.

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

Составьте программу,которая определяет,является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода:567.
Пример вывода:сумма цифр числа 567-четное число



Вы находитесь на странице вопроса "требуется найти сумму цифр числа( 5.....5)²,где 0< n<19000. Составьте программу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.