Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

5-9 класс

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

алина555666 25 марта 2014 г., 15:09:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anyakursina
25 марта 2014 г., 16:19:55 (10 лет назад)

var a,af,al:integer;
begin
  writeln('Введите число');
  readln(a);
  if a<10 then writeln('Ответ: ',a)
  else
  if a<=99 then
  begin
  af:=a div 10;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=999 then
  begin
  af:=a div 100;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=9999 then
  begin
  af:=a div 1000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=30000 then
  begin
  af:=a div 10000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end;
end.

Ответить

Другие вопросы из категории

Для каждого четырёхзначного числа из диапазона от A до B включительно

( A<B)требуется найти произведение средних разрядов (сотни, десятки), и вычислить сумму этих произведений.

в чашке стакане кувшине и банке находятся молоко, лимонад, квас и вода. известно, что вода и молоко не в чашке; сосуд с лимонадом стоит между кувшином

и сосудом с квасом. в банке не лимонад и не вода, а стакан стоит между банкой и сосудом с молоком. где находится квас?

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

Программа в Паскале! "Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Отдал все пункты что есть! Помогите!



Вы находитесь на странице вопроса "Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.