Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите,пожалуйста, решить задачу.Удалить элемент массива целых чисел с(25),кратный 5.Если таких элементов нет, выдать сообщение"Элементы для

5-9 класс

удаления не найдены".Если таких элементов несколько удалить последний из найденных. Записать в пасале

Shuraderk 22 мая 2013 г., 14:24:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Зайкаооо
22 мая 2013 г., 15:58:30 (10 лет назад)

Var a:array[1..5]of integer;   
i,n:integer;
Begin
Writeln ('Ââåäåííûé ìàññèâ');
For i:=1 to 5 do 
Begin 
read (a[i]); 
if a[i]mod 5=0 then n:=i; 
end;
if n=0 then writeln ('Ýëåìåíòû äëÿ óäàëåíèÿ íå íàéäåíû');
Writeln ('Íîâûé ìàññèâ');
For i:=1 to 5 do if i<>n
then write (a[i],' ')                         
else write ('# ');
end.

Ответить

Другие вопросы из категории

11011001+10111101

Информатика

1. С помощью каких органов чувств люди и животные получают информацию об объектах в приведённых ниже примерах:

а) мальчик ест арбуз;
б) девочка собирает в поле букет цветов;
в) мужчина выбирает книгу в магазине;
г) слепой человек читает книгу с использованием азбуки Брайля;
д) волк охотится за зайцем;
е) спортсмен ныряет в воду.

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Решение задач с использованием массивов / Pascal (Паскаль)

Помогите, пожалуйста, решить задачу!

Определить количество дней в первой декаде месяца, когда температура была выше средней.
Исходные данные: T - массив температуры
Промежуточные данные: i - порядковый номер
SUM - суммированная температура за 10 дней
SRT - средняя температура за 10 дней
Результирующие данные: K - количество дней с температурой выше средней
SUM:=SUM+T[i]
SRT:=SUM/10
K:=K+1, если выполняется SRT<T[i]
_______________________________
Program KTD
var T:array [1..10] of real;
SUM, SRT:real;
i,K:byte;

Помогите пожалуйста решить задачи!!!

Задание 1. Составить программу для вычисления по формуле:

Y = √|2x² - 7x| + 12
Задание 2.
Составить программу для вычисления значения функции:
F(x) = \left \{ {{0, If x <=2} \atop {1/(x^{2}+ 6), if x>1 }} \right. {{

Задание 3. Дано натуральное N. Вычислить: S=2*4*6*...*2N.
Задание 4. Дан массив А(20), заполненный датчиком случайных числе. Найти среднее арифметическое всех элементов массива.
Задание 5. дана матрица А(10,10), заполненная датчиком случайных чисел. Найти сумму значений всех элементов данной матрицы.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

Помогите, пожалуйста, решить задачу на языке программирования в Turbo Pascal: 1.Дан массив целых чисел, состоящий из 10 элементов.Заполнить его

с клавиатуры. Найти:
-Удвоенную сумму положительных элементов;
-вывести индексы тех элементов, значения которых больше значения предыдущего элемента(начиная со второго).

2.Определить,есть ли 2 пары соседних элементов с одинаковыми знаками.



Вы находитесь на странице вопроса "Помогите,пожалуйста, решить задачу.Удалить элемент массива целых чисел с(25),кратный 5.Если таких элементов нет, выдать сообщение"Элементы для", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.