Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Нехай деяка программа послідовно виконує операції, наведені нижче. Для кожного стовпчика вкажіть усі поточні значення величин. Скільки разів змінює своє

5-9 класс

значення кожна величина?
х: = 5;
у: = х - 5;
d: = 6 * у * у - х * у + 12;
у: = у * х / d + d * (d + 5) - х;
х: = у + d - х;
d: = х * 2 + 4.78;

сокол911 08 окт. 2014 г., 6:59:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ымиодлтдь
08 окт. 2014 г., 8:24:00 (9 лет назад)

Ox, no. What? What?What?

Ответить

Читайте также

вариант 1

1.По какой команде будет выведено значение величины Х?
1)readln(x);
2)read (x);
3)write( 'x' );
4)write(x).
2.Найдите синтаксические ошибки в программе:
Program Pr;
Var a,b.c: real;
Begin
write 'введите два числа ;
read a,b;
c=a/b*0,01
wrire ('c=,c');
End.
3.Какое значение пример переменная z после выполнения команд:
z:=0; x:=-1; y:=-1;
if x>0 then z:=1
else z:=2;
1)2; 2)-1; 3)1; 4)0; 5) ни один из ответов 1-4 не верен.
4.Какое логическое выражение нужно вписать во фрагмент программы,определяющий минимальный элемент массива F[1..N]?
x:=F[1];
For k:=1 to N do
If_________then x:=F[k];
1)F[k]<x; 2)F[k]>=F[k-1]; 3)F[k]<0; 4)k<=N;
2)ни один из ответов 1-4 не верен
5.Чему было равно значение переменной у,если после выполнения операций
i:=10;
while i <>1 do
begin
y:=y*y;
i:=int ( i / 2 );
end;
оно стало равным 256?
1) 2; 2) -2; 3) 0; 4) 2 или -2; 5) ни один из ответов 1-4 не верен.
6.Что будет выведено на печать в результате выполнения следующих операторов :
а:='5'; b:=-5;
write (pred (a), succ (a), 'b=', 10+b);
1)'4' '6' b=5; 2) 64b = 10+b; 3)46b=5; 4)64b=5; 5) ни один из ответов 1-4 не верен.
7.Что будет выведено на печать в результате выполнения следующих операторов:
а:=1;
repeat
a:=а+1;
write ('a=',a);
until a=4;
1)a=2a=3a=4a=5a ; 2) a=2a=3a=4 ; 3)а=4 ; 4) а=3 ; 5) ни один из ответов 1-4 не верен.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с

клавиатуры символов и выводит результат сравнения на экран. например 'a'<'б', 'д'='д, 'я'>'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов



Вы находитесь на странице вопроса "Нехай деяка программа послідовно виконує операції, наведені нижче. Для кожного стовпчика вкажіть усі поточні значення величин. Скільки разів змінює своє", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.