Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т.

5-9 класс

Протестировать алгоритм для X=5 и Y=-11.

65489588 28 дек. 2013 г., 2:26:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ythjgfcre
28 дек. 2013 г., 3:32:39 (10 лет назад)

Program Pr1;

uses crt;

var x,y,t:integer;

Begin

clrscr;

readln(x,y);

t:=x;

x:=y;

y:=t;

writeln(x,y);

end.

+ 0 -
Anna123anna
28 дек. 2013 г., 4:23:13 (10 лет назад)

var
x,y,t:integer;
begin
write('x=');
readln(x);
write('y=');
readln(y);
t:=x;
x:=y;
y:=t;
writeln('x=',x,' y=',y);
readln;
end.

Ответить

Другие вопросы из категории

Помогите,пожалуйста,решить задачу!

Мой богатый дядюшка подарил мне один доллар в мой первый день рождения. В каждый день рождения он удваивал свой подарок и прибавлял к нему столько долларов,сколько лет мне исполнилось. Написать программу,указывающую,к какому дню рождения подарок превысит 100$.

Написать

на языке Паскаль алгоритм нахождения количества натуральных четырехзначных
чисел, каждое из которых не делится ни на 2, ни на 3.

Читайте также

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!! СРОЧНО НАДО !!!

Разработать схему алгоритма для ввода четырех целых чисел и вычисления их среднего арифметического. Протестировать алгоритм на различных исходных данных( включая вещественные числа) и доказать правильность его работы.

срочно подскажите мне!!!!

Дано целое число А. Если значение А > 0, то необходимо
увеличить его на единицу. Разработать схему алгоритма для решения этой
задачи. Протестировать алгоритм для A=5, A=-4, A=0. сделать в паскале.


Программу я написала:

Program n1;
var A: real;
begin
readln (a);
if a>0
then a:=a+1;
writeln;
end.


правильно или нет? и какие у меня должны выходить значения?



Вы находитесь на странице вопроса "Вводятся величины X,Y целого типа. Разработать схему алгоритма для обмена значений величин. Необходимо использовать вспомогательную величину Т.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.