Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом R и началом в точке O(a,b)

5-9 класс

Kucherina87 03 янв. 2015 г., 7:56:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Drumiantsieva
03 янв. 2015 г., 9:53:18 (9 лет назад)

var

 x, y, R, Oa, Ob: real;

 

begin

  writeln('Введите радиус окружности R');

  readln(R);

  writeln('Введите координаты центра окружности');

  readln(Oa, Ob);

  writeln('Введите координаты точки');

  readln(x, y);

  if (x > (Oa - R)) and (x < (Oa + R)) and (y  > (Ob - R)) and (y < (Ob + R)) then

    writeln('Точка с заданными координатами лежит внутри круга')

  else

    writeln('Точка с заданными координатами лежит вне круга');

end. 

Если все правильно, отметь решение как лучшее)

Ответить

Читайте также

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

помогите пожалуйста решить задачу в паскале: Составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е.

таким,которое читается одинаково слева направо и справа налево(например:23132).



Вы находитесь на странице вопроса "составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом R и началом в точке O(a,b)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.