Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста!!!!!

5-9 класс

Turbo Pascal
Создайте массив, содержащий 15 различных символов.
Отсортируйте его по убыванию. После этого определите и выведите на экран
«наименьший» и «наибольший»

символы.




Dariadumitras 17 февр. 2015 г., 7:12:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Utazetdinov
17 февр. 2015 г., 8:42:06 (9 лет назад)

var j, i, x:integer; a: array [1..20] of integer;
begin
     randomize;
     writeln();
     for i := 1 to 15 do
         a[i] := random(1000);
     for i := 2 to 15 do
         for j := 15 downto i do
             if a[j] > a[j - 1]
             then
             begin
                  x := a[j];
                  a[j] := a[j - 1];
                  a[j - 1] := x;
             end;
     write(a[15], ' ', a[1]);
end.

Ответить

Другие вопросы из категории

назовите имена объектов
Решение задач с использованием массивов / Pascal (Паскаль)

Помогите, пожалуйста, решить задачу!

Определить количество дней в первой декаде месяца, когда температура была выше средней.
Исходные данные: T - массив температуры
Промежуточные данные: i - порядковый номер
SUM - суммированная температура за 10 дней
SRT - средняя температура за 10 дней
Результирующие данные: K - количество дней с температурой выше средней
SUM:=SUM+T[i]
SRT:=SUM/10
K:=K+1, если выполняется SRT<T[i]
_______________________________
Program KTD
var T:array [1..10] of real;
SUM, SRT:real;
i,K:byte;

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.