Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.найдите сумму элементов

10-11 класс

2.сформируйте массив

Bombochka98 23 дек. 2016 г., 0:29:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
RFrag
23 дек. 2016 г., 1:41:01 (7 лет назад)

var x, y, i, c, s: integer;
begin
     readln(x, y);
     if (x < y) then
     begin
        for i := x to y do
        begin
             c := c + 1;
             s := s + i;
        end;
        writeln('S = ', s, ' C = ', c);
     end;
end.

2)
const N = 10;
var a, c: array [0..N] of integer;
    i: integer;
begin
     for i := 0 to N do
         a[i] := random(50);
         
     for i := 0 to N do
     begin
         if (a[i] mod 2 = 0) then
            c[i] := a[i] * a[i]
         else
             c[i] := 2 * a[i] * i;
     end;
{Вывод массива, это для проверки, не обязательно, но если хотите...}
     for i := 0 to N do
         writeln('[', i, '] => ', c[i]);
end.

Учителям информатики очень лень говорить домашку х)

Ответить

Другие вопросы из категории

Приближается очередная олимпиада по программированию, и товарищи A и B решили устроить совместную тренировку. Они выбрали n задач и договорились, что

тренировка продлится t минут.Для каждой задачи известно время si (i = 1; 2; : : : ; n), которое потребуется на её решение. Уровень подготовки у товарищей A и B одинаковый, и если товарищ A решает некоторую задачу за время s, то и товарищ B решает эту задачу за это же время s.Товарищ A начал решать задачи с первой и будет решать их подряд, двигаясь от первой к последней и не пропуская ни одной. Товарищ B начал решать задачи с последней и тоже будетрешать их подряд, двигаясь от последней к первой и не пропуская ни одной.Ваша же задача — определить, сколько задач решат в течение тренировки товарищи A и B.В качестве ответа выведите два целых числа: количество задач, которые решит товарищ A, и через пробел — количество задач, которые решит товарищ B.

Формат входного файла

В первой строке содержатся через пробел два целых числа — n (1 n 100) и t (1 t 1000).
Во второй строке содержатся n целых чисел s1; s2; : : : sn (1 si 1000; i = 1; 2; : : : ; n), также отделённые друг от друга пробелом.

Формат выходного файла

В единственной строке выходного файла содержатся два целых числа через пробел — количество задач, которые решит товарищ A, и количество задач, которые решит товарищ B соответственно.

На Паскаль :)

Помогите написать программу в паскале. За ранее спасибо.

Задача на дыемерный. массив.

Читайте также

1) найди последний элемент массива меньше заданного числа

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!

Дано: массивы R(10),Q(10),P(10). Сформировать массив X(3),где X(1) - сумма элементов массива R, значения которых лежат в интервале [2;4];

X(2) - то же для массива Q;

X(3) - то же для массива P.

Вычисление суммы элементов массива, значения которыхлежит в интервале [2;4], оформить в виде подпрограммы.

PascalABC

Вот такие задачи нам задают.Прошу помощи.Заранее спасибо =)

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!

Одномерный массив состоит из 18 значений [1,2,3,4,5,6,6,5,4,3,2,1,1,2,3,4,5,6]. Найдите сумму элементов, которые не изменят свои значения после выполнения

представленной ниже блок-схемы. Индексация элементов массива начинается с единицы. В ответе укажите только число.



Вы находитесь на странице вопроса "1.найдите сумму элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.