Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1) найди последний элемент массива меньше заданного числа

10-11 класс

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!

НеПоСеДкА 05 мая 2014 г., 3:50:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
B1fidok
05 мая 2014 г., 5:51:03 (9 лет назад)

1)program Mas;uses crt; const nmax=100; var x:array[1..nmax]of Integer; i,n,b,bcol,proz:Integer; begin proz:=1; repeat begin ClrScr; Write('Введите размер одномерного массива(n),n='); Read(n); end; until n<=nmax; Writeln('Введите значения элементов массива:'); for i:=1 to n do Read(x[i]); Writeln('Введенный массив:'); for i:=1 to n do Write(x[i],' '); Writeln; Write('Введите число B:'); Read(b); for i:=1 to n do if x[i]<b then inc(bcol); Writeln('Количество элементов меньших B:',bcol); for i:=1 to n do proz:=proz*x[i]; Writeln('Произведение всех элементов массива:',proz); Readln; end.
2)

+ 0 -
Luella
02 июля 2016 г., 11:34:41 (7 лет назад)

Any thoughts on the fact that this poll was done in May? I’ve been noticing some significant momentum for Capriles as far as mind-share is concerned. But he needs to get out of the northern st32aste0;

+ 0 -
Issy
03 июля 2016 г., 5:32:07 (7 лет назад)

The expirtese shines through. Thanks for taking the time to answer.

+ 0 -
Peerless
04 июля 2016 г., 15:03:15 (7 лет назад)

Time to face the music armed with this great iniromatfon.

+ 0 -
Х167
05 мая 2014 г., 8:40:24 (9 лет назад)

Комментарий удален

+ 0 -
Darinakorbyt
05 мая 2014 г., 10:01:01 (9 лет назад)

всмысле балов много ?

+ 0 -
Dmitriy0179
05 мая 2014 г., 12:06:37 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Написать

программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3
- лето, 4 - осень) выдавала соответствующие этому времени года месяцы,
количество дней в каждом из месяцев.

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Программирование в VBA. Задача:Массив сотоит из двадцати элементов. Сколько элементов массива нужно сложить (начиная с первого), чтобы сумма превысила

число 100. Вот моя программа:

Private Sub CommandButton1_Click()
Dim C(1 To 20) As Integer
Dim I, N, S As Integer
For I = 1 To 20
C(I) = Cells(I, 1)
Next I
S = 0
N = 0
For I = 1 To 20
If S <= 100 Then S = S + C(I) And N = N + 1
Next I
Cells(2, 3) = "Количество элементов массива, сумма которых превышает 100=" & N
End Sub

как результат выводит "0" (т.е. N заданное изначально). Может, кто-то сможет подсказать ошибку? Это срочно!

Задача 7. Найти первый и последний элементы массива, кратные

числу 3.
Пример: массив 7 2 6 5 4 4 10 3 9
элементы, кратные 3 6 39
первый и последний из них 6 9



Вы находитесь на странице вопроса "1) найди последний элемент массива меньше заданного числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.