Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задачи на массив в Turbo Pascal

10-11 класс

1) Определите ,на сколько отличается рост самого высокого и самого низкого учащегося в классе?
2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива -год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.
3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

Hghjgfgdjhdfudutd 12 апр. 2013 г., 1:40:48 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sgfbdhergfhfhfh
12 апр. 2013 г., 3:18:05 (11 лет назад)

program gt;
var n,i,max,min:integer;
a:array[1..100]of integer;
begin
read(n);
{n-кол-во учащихся}
for i:=1 to n do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to n do
begin
if(a[i]>max)then max:=a[i];
if(a[i]<min)then min:=a[i];
end;
writeln(max,' ',min,'-росты')
max:=max-min;
writeln(max);
end.
2)
program gt;
var n,i,a,k:integer;
begin
read(n);
k:=0;
for i:=1 to n do
begin
read(a);
if(a<1958)then k:=k+1;
end;
writeln(k);
end.
3)
program gt;
var i,q,a,l:integer;
begin
for i:=8 to 20 do
begin
read(a);
if(a<0)then begin
q:=q+1;
if(q=1)then l:=i;
end;
end;
writeln(l);
end.

Ответить

Другие вопросы из категории

некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала записывается цифра, следующая за последней в исходной

цепочке, затем исходная цепочка дважды: в прямом и обратном порядке. Дана цепочка 71. Какая цепочка получитчся, если к ней применить алгоритм дважды?

реббят помогитее .....

Читайте также

Доброго времени суток, помогите пожалуйста с решением данной задачи, необходим код, для Turbo Pascal. Сама задача звучит так:

С клавиатуры вводится 3 числа, если сумма первого и последнего больше 10, то вывести эту сумму, если произведение больше 20, но меньше 30 (20>>30) то вывести это произведение, в противном случае вывести все эти 3 числа.

Сделать следущие задачи на языке pascal abc

#2. Ввести В. Если В<10, выдать на печать 2*В. Если В>=10, вычислить и напечатать значения функции y=x²-x+tg(1/B+x) для значений x, изменяющихся от –3 до 1, с шагом 0,1.
#3. Ввести массив целых чисел Х(n). Найти среднее арифметическое значений элементов массива, не принадлежащих интервалу [-2;2]. Если среднее арифметическое значение>2, заменить значения первого и последнего элементов на 1, в ином случае – на 0. Массив распечатать.
#4. Ввести массив А(n). Найти сумму положительных элементов массива, исключая при этом те элементы, которые кратны трём. Полученной суммой заменить элементы 2-ой половины массива. Массив отпечатать.

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.



Вы находитесь на странице вопроса "Задачи на массив в Turbo Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.