Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль помогите пожалуйста

10-11 класс

Тип данных Массив от 1 до 10 с элементами типа Integer создать алгоритм который вычеслит произведение парных чисел

Kristina549 12 марта 2014 г., 9:48:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergei200
12 марта 2014 г., 12:20:44 (10 лет назад)

var
  a: array [1..10] of Integer;
  i, p : Integer;
begin
  for i := 1 to 10 do
  begin
    Write('a[', i, '] = ');
    Readln(a[i]);
  end;

  for i := 1 to 10 do
    if a[i] mod 2 = 0 then p := p * a[i];

  Writeln(p);
end.

+ 0 -
Vipkirir
12 марта 2014 г., 12:56:49 (10 лет назад)

Program Bi3;
var    
a:integer;   
pr:integer;   
 i:integer;
begin
a[0]:=0;
pr:=1;
writeln('Введите ваше число');
for i:=1 to 10 do begin   
readln(a[i]);   
If (a[i]-a[i-1]=2) then begin   
pr:=pr*a[i];end;end;End.

Ответить

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста :(((

Даны шесть монет, из которых одна фальшивая. Фальшивая монета отличается от настоящей монеты весом, причем она либо немного тяжелее, либо немного легче. Имея рычажные весы, определить ложную монету не более чем за три взвешивания.
Это в паскале надо)
Пожалуйста!!!!))))



Вы находитесь на странице вопроса "Паскаль помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.