Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите, пожалуйста, очень, очень надо. Написать программу с помощью цикла, которая позволяет ввести с клавиатуры последовательность из трех

10-11 класс

дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. Ниже представлен рекомендуемый вид экрана во время работы программы:

*Обработка последовательности дробных чисел*

После ввода каждого числа нажмите <Enter>

- > 12.3

Введено чисел: 1 Среднее арифметическое: 12.30

- > 15

Введено чисел: 2 Среднее арифметическое: 13.65

- > 10

Введено чисел: 3 Среднее арифметическое: 12.43

Innazhe 29 мая 2014 г., 16:13:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alexej
29 мая 2014 г., 17:27:45 (9 лет назад)

var a: array[1..3] of real;

x: real;
i: shortint;
begin
writeln('После ввода каждого числа нажмите <Enter>');
a[1]:=0; a[2]:=0; a[3]:=0;
for i:=1 to 3 do begin
write('->');
readln(a[i]);
x := ((a[1]+a[2]+a[3])/i)*100;
x := round(x);
x := x/100;
writeln('Введено чисел: ',i,' Среднее арифметическое: ',x);
end;
end.

Ответить

Другие вопросы из категории

Выводится на экран последовательность 20 случайных чисел из промежутка

[-10,10]. Определить количество отрицательных чисел больших -5 в данной
последовательности.

расписать в паскале: На плоскости расположена окружность R в центре с началом координат.Определить положение точки X с координатами (A,B) относительно

окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью

Паскаль помогите пожалуйста

Тип данных Массив от 1 до 10 с элементами типа Integer создать алгоритм который вычеслит произведение парных чисел

Читайте также

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад

Помогите пожалуйста, очень надо :( "Расследование на диване" (по изображению - во влажениях) Итак, представьте: Вы

следователь-детектив. Наконец то вы ушли в отпуск и вы лежите на диване, читая книжку. Неожиданно раздался звонок в дверь. На пороге стояла взволнованная соседка. Оказалось, что она недавно нашла рисунок, на котором узнала своего сына. У сына есть друг Саша, который хорошо рисует, и она предполагает, что он нарисовал их отдых. Но женщина ничего не знала об этом событии, и очень просила вас помочь ей узнать как было дело. Взглянув на изображение (изображение во влажениях) вы смогли ответить на все ее вопросы:

1 . В какой день (число и месяц) начался этот отдых в лесу? 2. Сколько человек вместе с сыном жили в этом лагере? 3. На чем они приехали? 4. Какого числа был сделан рисунок? 5. В какое время суток был сделан рисунок? 6. Далеко ли от лагеря до ближайшего селения? 7. С какой стороны света дул ветер?

помогите пожалуйста очень надо!!!

Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его с элементом главной диагонали.
(на паскале)



Вы находитесь на странице вопроса "Помогите, пожалуйста, очень, очень надо. Написать программу с помощью цикла, которая позволяет ввести с клавиатуры последовательность из трех", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.