Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сделать проверку упорядоченности элементов одномерного массива по убыванию их значений.

10-11 класс

KYUI 10 марта 2017 г., 1:25:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
уииии3
10 марта 2017 г., 4:04:03 (7 лет назад)

Уж сколько раз твердили миру... чтобы языки указывали ._. Ну, ниже представлен пример для PascalABC

var

  a: array of integer := (9, 8, 7, 6, 7, 4, 3, 2, 1, 0);
  i: byte;
  b: boolean := true;

begin
  for i := 1 to length(a) - 1 do
    if (a[i] > a[i-1]) then
      b := false;
  writeln(b);
end.

+ 0 -
ВеликановаКсю
10 марта 2017 г., 6:06:43 (7 лет назад)

const
  n = 10;

var
  a: array[1..n] of integer := (1, 2, 3, 6, 4, 5, 9, 7, 8, 10);
  i: integer;

begin
  i := 0;
  repeat
    i := i + 1
  until (i = n) or (a[i] > a[i + 1]);
  if a[i] > a[i + 1] then
    Writeln('Нарушение на элементах ', i, ',', i + 1, ': ', a[i], '>', a[i + 1])
end.

Тестовое решение:
Нарушение на элементах 4,5: 6>4


Ответить

Другие вопросы из категории

Дан одномерный массив m состоящий из 12 целых чисел. Организовать

ввод массива случайным образом и найти:
1) количество нулевых элементов;
2) сумму элементов меньших 1

Help! Нужно построить блок-схему:(

function f(x:
real): real;

begin

if x < 0 then
f := exp(x * ln(3)) + sqr(x)

else f := exp(-x
* ln(3)) - sqr(-x)

end;



var

a, b, h, x, y:
real;



begin

a := -1; b := 2;
h := 0.2;

writeln('':10,
'_________________');

writeln('':10,
'| x
| y |');

Читайте также

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Используя матрицу размером 4х4 с картинки, максим создал одномерный массив размером 16 и заполнил его по следующему принципу. Двигаясь в матрице по

спирали в очередной элемент одномерного массива ( начиная с первого) он записывал элемент матрицы с нечетной суммой индексов. Затем, двигаясь в обратном направлении по этой же спирали, последовательно записывал в одномерный массив элементы матрицы с четной суммой индексов. Сколько четных элементов одновременно массива стоят на нечетных местах?
А) 8 Б) 2 В) 16 Г) 4
1 2 3 4
8 7 6 5|
9 10 11 12
16 15 14 13

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

Сортировка массивов по возрастанию и по убыванию. Массив задается от

датчика случайных чисел random(). Сортировать один и тот же исходный
массив и по убыванию и по возрастанию значений элементов.



Вы находитесь на странице вопроса "Сделать проверку упорядоченности элементов одномерного массива по убыванию их значений.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.