Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста.

5-9 класс

Составьте алгоритмы и напишите программы для решения задач: 1. Вводятся два числа. Если первое число больше второго, то напечатать их сумму, иначе напечатать их разность 2. Вводятся значения двух ЦИФР. Напечатать максимальное двузначное число, которое можно сформировать из этих цифр или сообщение, что таких двухзначных чисел не существует. 3. Вводится последовательность N чисел.Определите, каких чисел в последовательности больше: кратных 5 или нечетных.

SaBDaB 02 апр. 2017 г., 13:27:09 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Safonovanatasha33
02 апр. 2017 г., 14:02:59 (7 лет назад)

1)
var
a,b:integer;
begin
  read(a,b);
  if a>b 
   then
      write(a+b)
  else if b>a
            then
              write(b-a);
end.
2)
var
   a,b:integer;
begin
   read(a,b);
   if (a=0) and (b=0)
      then
         write(' Двузначного числа не существует')
   else
   if (a>b) and (a<10) and (a>=0) and (b<10) and (b>=0)
      then
         write(a,b)
   else   if (a<10) and (a>=0) and (b<10) and (b>=0)
      then
         write(b,a)
   else
       write(' Двузначного числа не существует')
end.
3)
var
   i,a,n,k5,ne:integer;
begin
   write('Введите N:');
   read(n);
   for i:=1 to n do
      begin
         read(a);
         if a mod 5 = 0
            then
               inc(k5)
            else if a mod 2 <> 0
               then
                  inc(ne);
      end;
if k5>ne
   then
      write('Кратных 5 больше')
   else if ne > k5
      then
         write('Нечетных больше')
    else
         write('Равное количество');
end.

Ответить

Другие вопросы из категории

3.. Дана зашифрованная пословица Чтобы рубить дрова, нужен 14,2,3,2,7, а чтобы полить огород – 10,4,5,1,6.

Рыбаки сделали во льду 3,7,2,7,8,9,11 и стали ловить рыбу.

Самый колючий зверь в лесу – это 12,13.

А теперь расшифруйте пословицу:

1,2,3,4,5,1,6

7,8,9,10,11

9,4,7,4,13,12,14

Помогите...

Написать программу для нахождения суммы цифр двузначного числа(в Pascal ABC)

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите, пожалуйста.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.