Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите с задачами по информатике решить 2 задачи и записать как в паскале

10-11 класс

Kutlunini 10 июля 2013 г., 12:50:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anton0969
10 июля 2013 г., 15:14:12 (10 лет назад)

Задача1. (на паскале давно не программировал, поэтому возможны огрехи, саого паскаля под рукой нет.)

 

Program zadanie1;

var

a,b,c: real;

begin

wtiteln('Vvedite A');

readln(a);

writeln('Vvrdite B');

readln(b);

writeln('Vvedite C');

readln(c);

if ((a>b)and(b>c))or((a<b)and(b<c)) then

   begin

   a:=a*2;

   b:=b*2;

   c:=c*2;

   end;

else

   begin

   a:=a*(-1);

   b:=b*(-1);

   c:=c*(-1);

   end;

writeln('a=');

writeln('b=');

writeln('c=');

end.

 

Решил исходя из того, что в случае если условие не выполняется значение чисел меняется на обратное по знаку.

 

Задача 2.

 

program Zadanie2;

 

var

 

A,B,C:integer;

 

begin

 

writeln('Введите числa A,B и C: ');

 

readln(A,B,C);

 

if (C = B) then

 

writeln('Номер числа, отличного от остальных: ',1)

 

else

 

if (A = C) then

 

writeln('Номер числа, отличного от остальных: ',2)

 

else

 

writeln('Номер числа, отличного от остальных: ',3);

 

end.


Ответить

Другие вопросы из категории

при поступлении в вуз абитуриенты получившие двойку на первом экзамене ко второму не допускаются. в массиве A[n] записаны оценки экзаменующихся,полученные

на первом экзамене. подсчитать, сколько человек не допущено ко второму экзамену .В Turbopascal

Читайте также

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.



Вы находитесь на странице вопроса "помогите с задачами по информатике решить 2 задачи и записать как в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.