Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите пожалуйста!! паскаль

10-11 класс

Входными данными являются число k, N и N целых чисел.
В массиве определить индекс k-го наибольшего элемента массива.
Считать, что все элементы разные.
Ограничения:
Считать, что все элементы разные.
N принимает значения от 1 до 20.
k принимает значения от 1 до N.
Формат входных данных:
k, N и N целых чисел
Формат выходных данных:
индекс второго наибольшего элемента массива

Alberto447 04 мая 2015 г., 16:49:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cerega1992
04 мая 2015 г., 18:57:45 (9 лет назад)

var
  i,j,n,k: integer;
  a,b:array[1..20]of integer;
begin
writeln('Введите N');
readln(n);
for i:=1 to n do
  begin
  readln(a[i]);
  b[i]:=a[i];
  end;
for i:=1 to n do
  for j:=1 to n do
    if b[i]>b[j] then
      begin
      k:=b[i];
      b[i]:=b[j];
      b[j]:=k
      end;
for i:=1 to n do
  if a[i]=b[2] then k:=i;
writeln('k=',k);
end.

Ответить

Другие вопросы из категории

а вы любите онлайн игры? мне нравится играть на этом сайте http://playalltime.net

может посоветуете ещё сыйты. спасибо.

В соревновании по бегу стартовало 143 спортсменов. Номер каждого спортсмены был зарегистрирован одинаковым минимально необходимым количеством бит.

Какой размер в битах будет иметь файл, в котором зарегистрированы номера 42 спортсменов, пересекших финиш?

Читайте также

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.



Вы находитесь на странице вопроса "помогите пожалуйста!! паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.