Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами.Формат входных данныхСначала

10-11 класс

задано число N

Elenachernykh 20 марта 2017 г., 13:33:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лиза20040314
20 марта 2017 г., 14:33:53 (7 лет назад)

вот массив который сам заполняется
uses crt;
const
n=100;
var
i,a:integer;
mas1: array [0..n] of integer;
begin
for i:=0 to n do
begin
a:=random(10000);
mas1[i]:=a;
end;
for i:=0 to n do
begin
if i mod 2=0 then
write('A[',i,']=',mas1[i],' ');
end;
end.

вот заполняемый вручную(чтобы записывать через пробел сам измени)))
uses crt;
const
n=100;
var
i,a:integer;
mas1: array [0..n] of integer;
label 1;
begin
for i:=0 to n do
begin
1:read(a);
if a<=10000 then
mas1[i]:=a
else
begin
writeln('a bolwe 10000');
goto 1
end;
end;
for i:=0 to n do
begin
if i mod 2=0 then
write('A[',i,']=',mas1[i],' ');
end;
end.

Ответить

Другие вопросы из категории

Написать программу на Паскаль

В одномерном массиве, из n действительных элементов, посчитать сумму негативных элементов массива

Пожалуйста, помогите составить программу в паскале. В массиве X(N) каждый элемент равен 0, 1 или 2. Переставить элементы массива так, чтобы сначала

располагались все единицы, затем все двойки и, наконец, все нули (дополнительного массива не заводить).

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1) Определите и выведите на экран количество чисел от 50 до 500, которые делятся на 11 и 13 одновременно. 2) Дан массив целых чисел, состоящий из 100

элементов. Заполнить его с клавиатуры. Найти:

а) удвоенную сумму положительных элементов;

б)вывести индексы тех элементов, значения которых больше значения предыдцщего элемента ( начиная со второго)

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

Дан массив целых чисел из n

элементов, заполненный случайным образом числами из промежутка [-10,60]. Удалить из него все элементы, в
которых последняя цифра нечетная, а само число кратно 3.
Помогите пожалуйста решить в C# (Си шарп)

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов



Вы находитесь на странице вопроса "Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами.Формат входных данныхСначала", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.