Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Заданы М строк слов, которые вводятся с клавиатуры. Подсчитать количество гласных букв в каждой из заданных строк

10-11 класс

Harif 15 февр. 2017 г., 6:36:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stalker932008
15 февр. 2017 г., 9:34:11 (7 лет назад)

На python:

 

def CountVowel(string):
    countVowel = 0;
    for i in string:
        if  i == 'а' or i == 'е' or i == 'ё' or i == 'и' or i == 'о' or i == 'у' or i == 'ы' or i == 'э' or i == 'ю' or i == 'я':
           countVowel+=1
    return countVowel       
lst = ['кошка','кофе','телевизор','автомобиль']
rang = range(len(lst))
for i in rang:
    lst[i] = CountVowel(lst[i])
print(lst)


Ответить

Читайте также

Здравствуйте! Позарез нужна программа в Паскале, вот условие:

"Разработать программу,
которая осуществляет в текстовом файле поиск заданных слов. Слова
последовательно вводятся с клавиатуры. Для каждого слова должно определяться
количество вхождений и номера строк текста. Если указанное слово в файле
отсутствует, то программа должна выводить соответствующее сообщение."
И если можно, то и блок-схему.
Заранее спасибо!

Ребятки помогите!!!! 1.Написать программу нахождения периметра треугольника .Значение сторон вводятся с клавиатуры. 2. Написать программу

нахождения S прямоугольного треугольника. ЗНАЧЕНИЯ КАТЕТОВ ВВОДЯТСЯ С КЛАВИАТУРЫ!

ПОМОГИТЕ ЗАЙКИ,,,,,



Вы находитесь на странице вопроса "Заданы М строк слов, которые вводятся с клавиатуры. Подсчитать количество гласных букв в каждой из заданных строк", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.