Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

даны 10 произвольных действительных числа(вводятся с клавиатуры).Подсчитать количество отрицательных чисел помогите составить программу

10-11 класс

Elkabondarenko 20 марта 2015 г., 14:23:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
46788541
20 марта 2015 г., 16:00:13 (9 лет назад)

var a,s,i:integer;
begin
s:=0;
for i:=1 to 10 do
 begin
 write('Число: '); readln(a);
 if a<0 then s:=s+1;
 end;
writeln('Кол-во отрицательных чисел: ',s);
end.

+ 0 -
Butyrkinairina
20 марта 2015 г., 17:06:01 (9 лет назад)

Program Zorkini;
uses crt;
const n=10;
var
  Z: real;
  i,k: integer;
begin
  k:=0;
  for i:=1 to n do
  begin  
    write('Введите ',i,'-e число ');
    readln(z);
    if z<0 then k:=k+1;
  end;
  writeln('Количество отрицательных чисел ',k);
end.

Ответить

Другие вопросы из категории

Найти

количество нечетных элементов двумерного массива MASSIV [1..3,1..5]. Массив
заполните константами. Результат вывести на экран в виде: «Количество нечетных
элементов массива = …».

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

На каждой из 200 страниц книги содержится примерно 800 символов.
Выразите в килобайтах информационный объем книги, сохраненной в
16-битной кодировке unicode.

Постройте логические схемы и упростите логические выражения

1. F= A v B v (A v B)
2. F= (A v B) & C
3. F = (A v C) v (C & A)
____________________
Если не понятно скриншот --->

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a, b, c, пройти через прямоугольное отверстие со сторонами x и

y(при этом стороны параллелепипеда параллельны сторонам отверстия).Считать, что при равенстве размеров отверстия и кирпича кирпич не сможет пройти в отверстие.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых

цифр(включая однозначные числа). 2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры). 3. переставить первые три и последние три элемента местами, сохраняя их следование.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)



Вы находитесь на странице вопроса "даны 10 произвольных действительных числа(вводятся с клавиатуры).Подсчитать количество отрицательных чисел помогите составить программу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.