Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

5-9 класс

Паскаль

79247549445 11 янв. 2014 г., 11:08:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
JimmyPopisGod
11 янв. 2014 г., 13:09:30 (10 лет назад)

(Высчитывает сумму нечетных элементров массива) 

program chisla;
uses crt;
var a: array [1..10] of integer;    {сколько элементов вмассиве}
i,sum: integer;
begin
clrscr;
sum:=0;
for i:=1 to 10 do
begin
write('a[',i,']= ');
readln(a[i]);
if a[i] mod 2<>0 then sum:= sum+a[i];
end;
write('sum= ',sum);
readln;
end.

Ответить

Другие вопросы из категории

Компьютер состоит из устройств, выполняющих некоторые функции мыслящего человека. Проведите аналогию между человеком и компьютером и заполните таблицу.

Органы человека: органы чувств, мозг, мозг, органы речи и опорно-двигательной системы. Информационный процесс: приём (ввод) информации, хранение информации, обработка информации, передача (вывод) информации. Устройства компьютера......... Пожалуйста, помогите!

Помогите сделать пожалуйста!

1)В текстовом процессоре(редакторе)WordPad наберите слово "Информатика" и сохраните его в документе с именем D1,указав тип файла Текстовый документ.

Читайте также

Помогите, пожалуйста, написать программу, и составить блок-схему.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Найти и вывести на экран номера двух элементов массива, наименее отличающихся друг от друга.

помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0..100]. Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» . Вывести на экран число перестановок элементов массива в том и в другом случае. Массив выводить на экран не нужно.

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Найти значения минимального элемента одномерного целочисленного массива, сформированного пользователем, и его индекс.

Внимание, предусмотреть ситуацию нескольких элементов с минимальным значением. В этом случае вывести на экран все индексы. Паскаль.



Вы находитесь на странице вопроса "ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.