Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Кто знает как решать?

5-9 класс

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран
соответствующие результаты.

·

леннчиик 26 нояб. 2014 г., 7:00:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimasta4
26 нояб. 2014 г., 7:40:52 (9 лет назад)

Привет. Предлагаю тебе такое решение. Так как сам новичок, чуть-чуть попыхтел :)

program dlya_0101000;
var
a,b,c,d,p,l:integer;
m:boolean;
label 1,2;
begin
writeln ('Введите 4 произвольных числа, разделяя их пробелом');
read (a,b,c,d);
p:=b*d;
if (((b-d) mod 2)= 0) then writeln('Сумма ',(b+d), ' чётная. Два числа и их произведение: ',b*d)
else
goto 1;
m:=(a+c)>150;
if m=true then writeln ('Сумма чисел: ',a+c,'. Четыре числа: ',a,' ',b,' ',c,' ',d);
if (((b-d) mod 2)<>0) and (m=true) then writeln ('Произведение второго и чётвёртого: ',(b*d), ' .Сумма первого и третьего: ',(a+c));
goto 2;
1: writeln ('Четыре числа: ',a,' ',b,' ',c,' ',d);
2:end.


Ответить

Другие вопросы из категории

Напишите программу для паскаль авс

Задачи:
1.Ввести три целых числа, найти максимальное из них
2.Ввести пять целых чисел, найти максимальное из них

племя мульти пишет письма, пользуясь 16-символьным алфавитом .племя пульти пользуется 32-символьным алфавитом. вожди племен обменялись письмами,

содержащими одинаковое кол-во символов. сравните объемы информации, содержащиеся в письмах.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "Кто знает как решать?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.