Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

срочно, помогите, хотябы пару пунктов, желательно все((((((! Даны описания: type Oras = (Chisinau, Orhei, Balti, Tigina, Tiraspol);

10-11 класс

Zi = (L, Ma, Mi, J, V, S, D);

Consum = array [Oras, Zi] of real;

var C : Consum;

r : Oras;

z : Zi;

Компонента C [r,z] переменной C представляет собой потребление электроэнергии города r в день z. Напишите программу, которая :

а)вычисляет количество электроэнергии, поторебляемой каждым городом за неделю;

б)вычисляет количество электроэнергии, потребляемой данными городами ежедневно;

в) вычисляет город с максимальным еженедельным потреблением электроэнергии;

г) определяет город с минимальным еженедельным потреблением электроэнергии;

д) определяет день, в который было потреблено наибольшее количество электроэнергии;

е) определяет деь с наименьшим потреблением электроэнергии.

мила0902 26 дек. 2013 г., 2:29:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olgamit27
26 дек. 2013 г., 3:35:36 (10 лет назад)

type Oras = (Chisinau, Orhei, Balti, Tigina, Tiraspol);
Zi = (L, Ma, Mi, J, V, S, D);
Consum = array [Oras, Zi] of real;
var C : Consum;
r : Oras;
z : Zi;
i,k : integer;
sum,min_r,max_r,min_z,max_z:real;
n_max_r,n_min_r,n_max_z,n_min_z:integer;
begin
r:=Chisinau;
randomize;
for i:=1 to 5 do
begin
z:=L;
for k:=1 to 7 do
begin
c[r,z]:=random*100;
z:=succ(z);
end;
r:=succ(r);
end;
r:=Chisinau;
for i:=1 to 5 do
begin
z:=L;
case ord(r) of
0:writeln('Chisinau');
1:writeln('Orhei');
2:writeln('Balti');
3:writeln('Tigina');
4:writeln('Tiraspol');
end;
for k:=1 to 7 do
begin
write(c[r,z]:6:2);
z:=succ(z);
end;
r:=succ(r);
writeln;
end;
writeln('Vsego za nedelu');
r:=Chisinau;
min_r:=99999;
max_r:=0;
n_min_r:=-1;
n_max_r:=-1;
for i:=1 to 5 do
begin
z:=L;
case ord(r) of
0:write('Chisinau sum=');
1:write('Orhei sum=');
2:write('Balti sum=');
3:write('Tigina sum=');
4:write('Tiraspol sum=');
end;
sum:=0;
for k:=1 to 7 do
begin
sum:=sum+c[r,z];
z:=succ(z);
end;
if sum>max_r then
begin
max_r:=sum;
n_max_r:=ord(r);
end;
if sum<min_r then
begin
min_r:=sum;
n_min_r:=ord(r);
end;

r:=succ(r);

writeln(sum:8:2);
end;
writeln('Po dnyam nedeli');
z:=L;
min_z:=99999;
max_z:=0;
n_min_z:=-1;
n_max_z:=-1;

for k:=1 to 7 do
begin
r:=Chisinau;
case ord(z) of
0:write('L sum=');
1:write('Ma sum=');
2:write('Mi sum=');
3:write('J sum=');
4:write('V sum=');
5:write('S sum=');
6:write('D sum=');
end;
sum:=0;
for i:=1 to 5 do
begin
sum:=sum+c[r,z];
r:=succ(r);
end;
if sum>max_z then
begin
max_z:=sum;
n_max_z:=ord(z);
end;
if sum<min_z then
begin
min_z:=sum;
n_min_z:=ord(z);
end;
z:=succ(z);
writeln(sum:8:2);
end;
writeln('Gorod c maximalnim potrebleniem');
r:=Chisinau;
for i:=1 to 5 do
begin
if ord(r)=n_max_r then
case ord(r) of
0:writeln('Chisinau');
1:writeln('Orhei');
2:writeln('Balti');
3:writeln('Tigina');
4:writeln('Tiraspol');
end;
r:=succ(r);
end;
writeln('Gorod c minimalnim potrebleniem');
r:=Chisinau;
for i:=1 to 5 do
begin
if ord(r)=n_min_r then
case ord(r) of
0:writeln('Chisinau');
1:writeln('Orhei');
2:writeln('Balti');
3:writeln('Tigina');
4:writeln('Tiraspol');
end;
r:=succ(r);
end;

writeln('Den c maximalnim potrebleniem');
z:=L;
for k:=1 to 7 do
begin
if ord(z)=n_max_z then
case ord(z) of
0:writeln('L');
1:writeln('Ma');
2:writeln('Mi');
3:writeln('J');
4:writeln('V');
5:writeln('S');
6:writeln('D');
end;
z:=succ(z);
end;
writeln('Den c minimalnim potrebleniem');
z:=L;
for k:=1 to 7 do
begin
if ord(z)=n_min_z then
case ord(z) of
0:writeln('L');
1:writeln('Ma');
2:writeln('Mi');
3:writeln('J');
4:writeln('V');
5:writeln('S');
6:writeln('D');
end;
z:=succ(z);
end;

readln;

end.

Ответить

Другие вопросы из категории

Решите пожалуйста очень срочно надо

1) Дано четырехзначное число. Верно ли, что среди его цифр есть кратные трем
2) Даны три целых числа. Вывести среднее значение числа (средним числом назовем то, которое меньше наибольшего, но больше наименьшего числа)
3) Напишите эффективную программ, которая по двум данным натуральным числам х и у, не превосходящим 10000, подсчитывает количество натуральных чисел, заканчивающихся нулем, на отрезке [х,у] (включая концы отрезка).

Читайте также

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

СРОЧНО:( ПОМОГИТЕ(((((

Дан двумерный массив. Все его элементы разделить на первый элемент и вывести на экран полученный массив.

ПОМОГИТЕ СРОЧНО ПЖЛСТ!!!

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Срочно помогите!!

Дан массив из 10ти целых чисел , введенных с клавиатуры. Найти и заменить все нулевые элементы на минимальный элемент массива.



Вы находитесь на странице вопроса "срочно, помогите, хотябы пару пунктов, желательно все((((((! Даны описания: type Oras = (Chisinau, Orhei, Balti, Tigina, Tiraspol);", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.