Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определите значение переменной b после выполнения фрагмента алгоритма.

5-9 класс

Kblva 30 июня 2016 г., 14:24:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
однокласс
30 июня 2016 г., 15:56:46 (7 лет назад)

б=0+3=3
б=3+4=7
б=7+5=12
б=12+6=18
б=18+7=25
Ответ:б=25
P.S. Pascal ABC
var a,b:integer;
begin
a:=2;
b:=0;
while a<>7 do
begin
a:=a+1;
b:=b+a;
end;
writeln(b);
end.

Ответить

Другие вопросы из категории

Читайте также

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

1). Определите значение переменной a после выполнения данного алгоритма :

b := 8
a := 10
b := b+a*2
a := 29-a
В ответе укажите одно целое число - значение переменной a

2). Переведите число 1101011 из двоичной системы счисления в десятичную систему счисления. В ответе напишите полученное число.

3). У исполнителя Удвоитель две команды, которым присвоены номера :
1. умножь на 2
2. прибавь 3
Первая из них увеличивает число на экране в 2 раза, вторая - прибавляет к числу 3.

Составьте алгоритм получения из числа 4 числа 47, содержащий не более 5 команд. В ответ запишите норма команд.

Запишите значения переменной b после выполнения фрагмента алгоритма.

В ответе укажите одно число-значение переменной b

Определите значение переменной f после выполнения фрагмента алгоритма

f:=1
начало цикла для i от 1до 5
f:-fxi
конец цикла



Вы находитесь на странице вопроса "Определите значение переменной b после выполнения фрагмента алгоритма.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.