Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

все элементы заданного массива вещественных чисел A(N),начиная с первого по порядку элемента, уменьшить на единицу.Новый массив переписать в S(N).

5-9 класс

ПОМОГИТЕ ПОЖАЛУЙСТААААААА:*

Loki98 24 мая 2016 г., 18:41:01 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nanagogitidze
24 мая 2016 г., 20:35:03 (7 лет назад)

uses crt;
const n=20;
var a:array[1..n] of integer;
s:array[1..n] of integer;
i,j:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(20);
write(a[i]:3);
end;
writeln;
for i:=1 to n do
a[i]:=a[i]-1;
for j:=1 to n do
for i:=1 to n do
if i=j then s[j]:=a[i];
for j:=1 to n do
write(s[j]:3);
end.

+ 0 -
25037
24 мая 2016 г., 21:05:21 (7 лет назад)

program task;

var  i,n:longint;
a:array [0..10000] of real;
s:array [0..10000] of real;
beginwriteln('skolko elementov v massive?');
readln(n);
for i:=1 to n do begin
a[i]:=random(100);
end;
for i:=1 to n do begin
s[i]:=a[i]-1;
end;
for i:=1 to n do begin
writeln(s[i]:0:0);
end;
readln;
end.


//даже если расписывать всё и вся, что можно - получается так. 

+ 0 -
ВиторияЯ
24 мая 2016 г., 23:17:34 (7 лет назад)

Ввод массива стандартный, набирается самим компьютером наугад или вообще без ввода чисел?

+ 0 -
Татьяна141182
25 мая 2016 г., 1:18:16 (7 лет назад)

хз:D а программу как записать?:)*

Ответить

Другие вопросы из категории

Помогите!!!!

Или обоснуйте:)
Заранее спасибо!

Составить программу расчета значения функции

Z = |3 е
х+3 – 2 ln ху| + 1,8х
2 + 1 при любых значениях х и у. Результат вы-
вести в виде: при х= … и у=… z=…

Читайте также

Pascal Проверить присутствие в массиве вещественных чисел отрицательных элементов, квадрат которых больше 100. Ограничения: -число

элементов в матрице не более 10-ти

Порядок ввода исходных данных:

-число элементов в массиве

-элементы массива

Порядок вывода результатов:

-сообщение Элементы найдены или Элементы не найдены.

ПОМОГИТЕ!!!удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.если таких элементов несколько ,

удалить последний из найденных.Помогите решить в паскале.(вычислить средн.ариф.номер э-та,....)

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПОМОГИТЕ РЕШИТЬ ПОЖАЛУЙСТА! Заданы массивы A и B чисел (N=10) случайным образом. Сформировать новый массив, каждый элемент которого равен:

сумме этих массивов ; минимальную из соответствующих элементов этих массивов.



Вы находитесь на странице вопроса "все элементы заданного массива вещественных чисел A(N),начиная с первого по порядку элемента, уменьшить на единицу.Новый массив переписать в S(N).", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.