Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить задачу в Паскале. Заменить каждый элемент массива суммой соседних элементов

10-11 класс

STALKER15 01 дек. 2016 г., 23:48:03 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DarinaVoolf
02 дек. 2016 г., 0:56:29 (7 лет назад)

var
 n, i: integer; // i - счетчик, n - размерность
a: array [1..1000] of integer; // массив чисел.
begin
readln(n);
for i := 1 to n do
 read(a[i]);
a[1] := a[2];
for i := 2 to n - 1 do
a[i] := a[i - 1] + a[i + 1];
a[n] := a[n - 1];
for i := 1 to n do
write(a[i],' ');
end.

Ответить

Другие вопросы из категории

Форматы файловых презентаций?
Используя матрицу размером 4х4 с картинки, максим создал одномерный массив размером 16 и заполнил его по следующему принципу. Двигаясь в матрице по

спирали в очередной элемент одномерного массива ( начиная с первого) он записывал элемент матрицы с нечетной суммой индексов. Затем, двигаясь в обратном направлении по этой же спирали, последовательно записывал в одномерный массив элементы матрицы с четной суммой индексов. Сколько четных элементов одновременно массива стоят на нечетных местах?
А) 8 Б) 2 В) 16 Г) 4
1 2 3 4
8 7 6 5|
9 10 11 12
16 15 14 13

Читайте также

Помогите решить задачи по паскалю:

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите, пожалуйста, решить задачу в Паскале (программа выводит не правильный результат, а понять где допущены ошибки не могу).

Задать массив из 30 положительных элементов случайным образом.
• найти кол-во нечётных элементов всего массива;
• найти минимальный элемент;
• элементы, кратные 10, заменить единицами и вывести новый массив.



Вы находитесь на странице вопроса "Помогите решить задачу в Паскале. Заменить каждый элемент массива суммой соседних элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.