Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Програмирование) помогите

10-11 класс

Katusha200 10 марта 2017 г., 12:20:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Betirova
10 марта 2017 г., 13:01:50 (7 лет назад)

Uses crt;
Var a,b,c,sum,i:integer;
Begin
c:=0;
i:=0; 
    Writeln('Вводите числа, когда закончите - введите 0');   
       Repeat 
readln(a); 
    if (a mod 8 = 0) and (a<>0) then begin c:=1; sum:=sum+a; i:=i+1; end; 
    if abs(a)>30000 then write('ВНИМАНИЕ! ОШИБКА! ЧИСЛО НЕ ДОЛЖНО ПРЕВЫШАТЬ 30000 ПО МОДУЛЮ! ПЕРЕЗАПУСТИТЕ ПРОГРАММУ!'); 
b:=b+1;   
       Until(a=0) and (c=1) or (b>999); 
  writeln('Ср арифм. чисел, кратных 8 = ',sum/i);
End.

+ 0 -
Elenapersikoleg
10 марта 2017 г., 15:23:13 (7 лет назад)

на каком языке?

+ 0 -
Kondratyuk82
10 марта 2017 г., 16:07:55 (7 лет назад)

паскаль

+ 0 -
535ksusha535
10 марта 2017 г., 16:59:50 (7 лет назад)

и ещё вопрос, в каком ты классе? чтобы я знал на сколько простой должен быть ответ

+ 0 -
Latypov51
10 марта 2017 г., 18:26:20 (7 лет назад)

10

+ 0 -
LElizavetaY
10 марта 2017 г., 20:15:15 (7 лет назад)

щас напишу

Ответить

Другие вопросы из категории

по паскалю Записать условие, которое является ИСТИННЫМ, когда

а) каждое из чисел А и В больше 100;
б) только одно из чисел А и В четное;
в) хотя бы одно из чисел А и В положительно;
г) каждое из чисел А, В, С кратно трем;
д) только одно из чисел А, В и С меньше 50;
е) хотя бы одно из чисел А, В, С отрицательно.

помогите решить пожалуйста.

дано натуральное число n, вычислить 2^n

pascal

#include #include main(){ int key; printf("\n Нажмите одну из курсорных клавиш:\n"); key = getch(); key = getch(); switch (key){ case 77:

printf("стрелка вправо\n"); break; case 75: printf("стрелка влево\n"); break; case 72: printf("стрелка вверх\n"); break; case 80: printf("стрелка вниз\n"); break; default: printf(“нe стрелка\n"); }; getch(); } чего тут не так?

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Програмирование!!!, помогите)

Написать программы для выполнения следующих заданий:
Бесконечно печатать букву А: ААААААААААА.....
Ответ:
3. Задание
Бесконечно печатать 1000 999 998 997 996......


Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Програмирование) помогите", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.