Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны действительные числа x,y,z Если все числа положительны, увеличить их значения в 2 раза;во всех отальных случаях отрицательные числа заменить их

1-4 класс

модулями, а положительные оставить без изменения.(Надо написать программу на паскале)

N451333 05 мая 2015 г., 5:52:12 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sasha7199
05 мая 2015 г., 7:22:15 (8 лет назад)

var x,y,z:integer;          
begin
  write ('введите X: ');
  readln(x);
  write ('введите Y: ');
  readln(y);
  write ('введите Z: ');
  readln(z);
  if (x>0)and(y>0)and(z>0)then
     begin    x:=x+2; y:=y+2;z:=z+2;    end
     else     begin    x:=abs(x);y:=abs(y);z:=abs(z);    end ;
   writeln('x= ',x);
   writeln('y= ',y);
   writeln('z= ',z);
   end.

Ответить

Другие вопросы из категории

Заполните схему "Хранение информации"

(Если что,схема вот:
---------------------------------
|________________________________|
| |
| |

Информация. Информация
быстро долго
воспроизводится. хранится
-------------------- -----------------
|___________________| |________________|
(диск,книги,флешка)
\_____________________/
|
-----------------------
|______________________|

Что такое компьютерная экономика?
Впиши в фигуры имена авторов планов строительства ходов . Допиши в таблице названия множеств .

Впиши ответ на вопрос : " Чей план выберут мышата , если каждый из них согласен вырыть только один ход , и не кто не хочет попасть в лапы кота ? " .

Читайте также

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

Вася сосчитал количество цифр на клавиатуре из него вычел количество букв "F" (заглавных и строчных) на всех клавишах умножил полученное число на

количество стрелок и прибавил количество букв русского алфавита, начертание которых на клавиатуре совпадает с начертанием некоторых букв английского алфавита на клавиатуре. Какое число получилось у Васи, если он не допустил ошибок

Дано целое число i.

найти значение a,
где a=i^3, если i кратно 5
a=i^2, если i кратно 2.
a=2*i+1 в остальных случаях.

Паскаль

Решить задачи.
1. Дано трёхзначное число. Определить, сколько раз в нём встречается цифра 3.
2. Дано натуральное число. Получить все его делители и найти их сумму.



Вы находитесь на странице вопроса "Даны действительные числа x,y,z Если все числа положительны, увеличить их значения в 2 раза;во всех отальных случаях отрицательные числа заменить их", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.