Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

выполните алгоритм для заданных чисел начало ввод x y x=y да нет вывод x x больше y да нет x=x-y y=y-x стрелка вверх к вводу

5-9 класс

кошка1111111111 18 сент. 2013 г., 11:28:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анатолий1988
18 сент. 2013 г., 12:50:35 (10 лет назад)

что то типо такого??? напишите пожалуйста нормально или фото.

var x,y:integer;
begin cls;
read(x,y);
if x = y then
write(x)
else if x > y then x:=x-y else y:=y-x;
readln;
end.

Ответить

Другие вопросы из категории

помогите плиз)

Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (-20) до 20. Опишите на русском языке и на языке Паскаля алгоритм, который подсчитывает и выводит среднюю температуру почетным дням месяца.

Помогите пожалуйста)

1.Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов с четными значениями и четными индексами.
Пример ввода:4 5 6 3 9 8 4 10 7 2
2.Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 20 и выводит на экран элементы,значения которых больше 5 и меньше 15.

Читайте также

Выполнить задания, связанные с Turbo Pascal: 1) Какой оператор позволяет менять значения переменных и вычислять

значения выражений?

2) Выполнить алгоритм при x=345:

Начало

ввод x

a=x div 100

b=x div 10 mod 10

c=(a+b)/2

вывод a

вывод b

вывод c

конец

3) Что появится на экране после выполнения фрагмента программы:

a:=7;

b:=5;

a:=a-b;

Writeln(b-a*2);

Writeln('a=',a,'b=',b);

4) Дана сторона квадрата, найти его периметр.

5) Дано трёхзначное число. В нём зачеркнули последнюю справа цифру и приписали её в начале. Найти полученное число.

*Задачи 4 и 5 решить на языке программирования, используя математические функции.

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ: 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного

типа. Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ". 3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа. Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса



Вы находитесь на странице вопроса "выполните алгоритм для заданных чисел начало ввод x y x=y да нет вывод x x больше y да нет x=x-y y=y-x стрелка вверх к вводу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.