Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

C4.

10-11 класс

На плоскости дан набор точек с целочисленными координатами.Найти площадь наибольшего четырёхугольника ,у которого 2 точки лежат на оси ОХ,а 2 другие по разные стороны от оси ОХ.

Di2000ana 17 нояб. 2013 г., 3:37:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rizaja21
17 нояб. 2013 г., 4:42:39 (10 лет назад)

type
mas=array[,]of integer;
var
  i,n:integer;
  a:mas;
  b:array[1..4]of integer;
begin
write('Сколько точек: ');
readln(n);
setlength(a,3,n+1);
for i:=1 to n do
  begin
  write('Введите координаты точки: ');
  readln(a[1,i],a[2,i]);
  end;
for i:=1 to n do
  begin
  if a[2,i]=0 then
    begin
    if b[1]=0 then b[1]:=i else if a[1,i]<a[1,b[1]] then b[1]:=i;
    if b[2]=0 then b[2]:=i else if a[1,i]>a[1,b[2]] then b[2]:=i;
    end;
  if a[2,i]>0 then
    if b[3]=0 then b[3]:=i else if a[2,i]>a[2,b[3]] then b[3]:=i;
  if a[2,i]<0 then
    if b[4]=0 then b[4]:=i else if a[2,i]<a[2,b[4]] then b[4]:=i;
  end;
writeln('Координаты вершин четырехугольника с наибольшей площадью:');
for i:=1 to 4 do write('(',a[1,b[i]],';',a[2,b[i]],') ')
end.

+ 0 -
DaxxBeatzz
17 нояб. 2013 г., 6:48:17 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

1)
В управляющий совет школы входят родители, учителя и учащиеся школы, причем родителей должно бфть не менее одной трети от общего числа членов совета. В

настоящий момент в совет входит N чесовек, из них К родителей. Определите, сколько родителей нужно дополнительно ввести в совет, чтобы их число стало составлять не менее трети от числа членов совета.

Программа получает на вход два целых числа N и К (N>0, 0<=K<=N), записанные в отдельных строках, - текущее число члено совета и числао родителей в совете.

Программа должна вывести единственное число - минимальное число родителей, которое необходимо ввести в совет.

Читайте также

Помогите быстро пожалуйста целую

Среди приведенных записей отыщите формулу для электронной таблицы.

1) D5C8-A3B2;
2) A1= D5*C8-A3*B2;
3) D5*C8-A3*B2;
4) =D5*C8-A3*B2.

11. В ячейку С8 ввели формулу =(С6 – С7)*$D$4. Затем эту формулу распространили вправо. Какая формула содержится в ячейке F8?

Ответ: _____________________________________________________________________________



12. В ячейку F13 ввели формулу =F12 / $B$4. Затем эту формулу распространили вниз. Какая формула содержится в ячейке F15?

Ответ: _____________________________________________________________________________


13. В ячейки C3, C4, D3, D4 введены соответственно числа 10, 4, 6, 5.
Какое число будет находиться в ячейке D8 после введения в эту ячейку формулы =СУММ(C3:D4)?

1) 2; 2) 14; 3) 15; 4) 25.

14. Документом (объектом обработки) MS Excel является файл с произвольным именем и
1) расширением .doc
2) расширением .xls
3) расширением .bmp

15. В терминахMS Excel файл называется:
1) рабочим журналом
2) рабочей страницей
3) рабочей книгой

«Технология обработки числовой информации» Excel Вопрос 1. ЭТ – это 1)Прикладная программа, предназначенная

для обработки структурированных в виде таблицы данных

2)Прикладная программа для обработки кодовых таблиц

3)Устройство ПК, управляющее его ресурсами в процессе обработки табличных данных

4)Системная программа, управляющая обработкой табличных данных

Вопрос 2. ЭТ предназначена для

1)обработки числовых данных, представленных в виде таблиц

2)упорядоченного хранения и обработки значительных массивов данных

3)визуализации структурных связей между данными, представленными в виде таблиц

4)редактирования больших объемов информации

Вопрос 3. ЭТ представляет собой

1)совокупность пронумерованных столбцов и поименованных буквами латинского языка строк

2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов

3)совокупность пронумерованных строк и столбцов

4)совокупность строк и столбцов

Вопрос 4. Строки ЭТ

1)именуются пользователем произвольным образом

2)обозначаются буквами латинского языка

3)обозначаются буквами русского языка

4)нумеруются

Вопрос 5. Столбцы ЭТ

1)обозначаются буквами русского языка

2)нумеруются

3)обозначаются буквами латинского языка

4)именуются пользователем произвольным образом

Вопрос 6. Для пользователя ячейка ЭТ идентифицируется

1)адресом машинного слова ОП, отведенного под ячейку

2)специальным кодовым словом

3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка

4)именем, задаваемым пользователем

Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются

1)в обычной математической записи

2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования

3)по правилам, принятым исключительно для электронных таблиц

4)по правилам математики

Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,

принятыми в математике, в ЭТ, имеет вид

1)3* (А1+В1)/(5*(2*В1-3*А2))

2)3(А1+В1)/5*(2В1-3А2)

3)3(А1+В1)/(5*(2В1-3А2))

4)3*(А1+В1)/5*(2*В1-3*А2)

Вопрос 9. Среди приведенных отыщите формулу для ЭТ

1)А3В8+12

2)А1=А3*В8+12

3)А3*В8+12

4)=А3*В8+12

Вопрос 10. Запись формулы в ЭТ не может включать в себя

1)знаки арифметических опраций

2)числовые выражения

3)имена ячеек

4)текст

Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки

1)не изменяются

2)преобразуются вне зависимости от нового положения формулы

3)преобразуются в зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки

1)преобразуются в зависимости от нового положения формулы

2)не изменяются

3)преобразуются вне зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 13. Диапазон - это

1)совокупность клеток, образующих в таблице область прямоугольной формы

2)все ячейки одной строки

3)все ячейки одного столбца

4)множество допустимых значений

Вопрос 14. Активная ячейка - это ячейка

1)для записи формул

2)для записи чисел

3)для записи чисел, формул, текста

4)в которой выполяется ввод данных

Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=А2*С4

2)=А2*$С$4

3)=$А$2*С4

4)=A4*C4

Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=A2*5

2)=$A$2*4

3)=A2*$C$4

4)=$A$2*5

Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=$А$2*$С$4

2)=A2*$C$2

3)=$А$2*С4

4)=A4*C4

Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?

1)15

2)10

3)20

4)25

Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу

=СУММ(А1:В1)*2?

1)10

2)300

3)100

4)30

Вопрос 20. Сортировкой называют

1)процесс поиска наибольшего и наименьшего элементов массива

2)процесс частичного упорядочения некоторого множества

3)любой процесс перестановки

4)процесс линейного упорядочения некоторого множества

В ячейке D5 электронной таблицы записана формул. Эту формулу скопировали в ячейку C4. В результате знание в ячейке C4 вычисляется по формуле 3x+y, где x

- значение в ячейке C22, а y - значение в ячейке D22. Какая формула могла быть записана в ячейке D5?



Вы находитесь на странице вопроса "C4.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.