Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

35 баллов. Дан массив целых чисел А [10]. Найти количество элементов массивов кратных 2. Диапазон элементов от -1000 до 1000. Если задача решается

10-11 класс

написанием программы, то написать лучше в Паскале. Спасибо!

Asselka0401 15 окт. 2014 г., 9:41:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asaya
15 окт. 2014 г., 12:12:42 (9 лет назад)

В паскале давно не писал, поэтому подзабыл (но принцип как это сделать покажу)

Пускаешь цикл for, чтобы перебрать массив:
for (i=0;i<10;i++)
{

}

Внутри цикла пишешь условия проверки кратности:
if (A[i] mod 2 = 0)
{
kolvo=kolvo+1;
}

В итоге получится примерно:
begin
kolvo=0;
for (i=0;i<10;i++)
{
if (A[i] mod 2 = 0)
{
kolvo=kolvo+1;

}
write(kolvo);

P.S. Это без объявления переменных и заполнения массива. Надеюсь, стало понятно. Удачи!



Ответить

Другие вопросы из категории

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}


На световой панели в ряд расположены 7 лампочек. Каждая из первых двух лампочек может гореть красным, жёлтым или зелёным цветом. Каждая из остальных

пяти лампочек может гореть одним из двух цветов – красным или белым. Сколько различных сигналов можно передать с помощью панели (все лампочки должны гореть, порядок цветов имеет значение)?

--- Задача 7 ---

Просмотрщик
текстовых файлов. Написать программу, которая позволяет просматривать текстовые
файлы (выводит на экран содержимое файла). Имя просматриваемого файла должно
вводиться с клавиатуры. Вывод содержимого файла произвести постранично.

Примечание:
Результат работы с данными вывести на экран и в новый файл. Файл с входными
данными имеет название INPUT.TXT для текстовых файлов.


на PascakABC оч нужно..плизз

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

на языке паскаль 1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел

среди 10 элементов вещественного массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

1)дан массив натуральных чисел найдите сумму всех его элементов 2)вычислить количество положительных чисел среди 10 элементов вещественного

массива

3)заполнить массив из n целых чисел.выяснить какое число встречается раньше-положительное или отрицательное.

4)в целочисленном массиве есть отрицательные элементы.вывести номера этих элементов

дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых

цифр(включая однозначные числа). 2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры). 3. переставить первые три и последние три элемента местами, сохраняя их следование.



Вы находитесь на странице вопроса "35 баллов. Дан массив целых чисел А [10]. Найти количество элементов массивов кратных 2. Диапазон элементов от -1000 до 1000. Если задача решается", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.