Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ЭТО ОЧЕНЬ ВАЖНО ДЛЯ МЕНЯ и сложно, завтра зачет и будут такие задачи, помогите мне, пожалуйста, совершенно не смыслю в этом!

10-11 класс

ЗАДАЧИ К ЗАЧЕТУ ПО РАЗДЕЛУ: "ОСНОВЫ ПРОГРАММИРОВАНИЯ НА ПАСКАЛЕ"
1. Составьте программу для решения следующей задачи:
Найти длину окружности L=2*П(пи)*R и площадь круга S=П(пи)*Rв квадрате заданного радиуса R. В качестве значения П(пи) использовать 3,14.
2. Составить программу для решения задачи: Возраст Коли- Х лет, Миши- Y лет. Найти их средний возраст, а также определить, насколько отличается возраст каждого мальчика от среднего значения.
3. Составьте программу для решения следующей задачи: Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
4. Составьте программу для решения следующей задачи: Даны три числа. Найти сумму двух наибольших из них.
5. Составить программу для решения следующей задачи: Напечатать все целые числа от А до В в "столбик".
6. Составить программу для нахождения суммы: S= 1+ 1/2+1/3+...1/N
7. Составить программу для решения следующей задачи: Все четные положительные элементы массива из 20 целых случайных чисел в интервале [-15, 25] уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак.

Elvinafattaxov 17 янв. 2017 г., 15:03:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анжелика33
17 янв. 2017 г., 17:13:51 (7 лет назад)

Держи! Пять задач прикрепил. Остальные две никак. 

Ответить

Другие вопросы из категории

Каким образом сетевой адаптер может подключаться к компьютеру?

1) функции сетевого адаптера выполняет материнская плата

2) через интерфейс USB

3) через интерфейс PCMCIA

4) все ответы верны

5) через интерфейс PCI

Вывести на экран элементы массива которые являются делителями числа Х (Х-вводится с клавиатуры). (Элементов массива:10. Массив вводится cлучайным образом)

решите пожалуйста и опишите полностью, только решение должо быть простым не через процедуры а то я на 1 курсе мы еше это не проходили)

Помогите пожалуйста)Желательно подробно.

Ниже записан алгоритм. Получив на ход число x этот алгоритм , запишет две буквы M,L. Напишите число “x” при котором алгоритм с начало напишет число 2, а потом 8 .
DIM X, L, M AS INTEGER
INPUT X L=0: M=0
WHILE X>0
L=L+1
IF M<(X MOD 10) THEN M=X MOD 10
END IF
X=X\10
WEND
PRINT L, M

в паскале:
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do
begin
L:=L+1;
if M < (x mod 10) then begin
M:=x mod 10;
end;
x:= x div 10;
end;
writeln(L);
write(M);
end.

Читайте также

Циклические алгоритмы :ссс

Ребят, очень нужно, как можно скорее. Желательно- весь тест.
Для тех, кто понимает, он не сложный. А я вообще не смыслю в этом :с
[прикрепляю фотку посветлее и потемнее]

в Pascal ABC

кто еще знает такую задачу помогите кому не сложно)
Программа которая будет определять нечетное количество цифр, содержащихся в тексте

Для некоторых это будет легко,но для меня трудно.У меня идеи есть,но до сих пор не получается реализовать,чтобы все работало.

Я прошу помочь с выполнением задачи.
Напишите пожалуйста код в C++, который делает следующее:
Найти номер элемента массива,модуль разности сумм чисел слева и справа от которого наименьший.Значение элемента с этим номером при суммировании не учитывается.Номера элементов начинаются с 0.
Допустим элементы последовательности такие : 1,2,3,4,5,6,2.
Ответ:номер элемента 4.,т.е. это число 5 последовательности.
Помогите пожалуйста написать код.



Вы находитесь на странице вопроса "ЭТО ОЧЕНЬ ВАЖНО ДЛЯ МЕНЯ и сложно, завтра зачет и будут такие задачи, помогите мне, пожалуйста, совершенно не смыслю в этом!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.