Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны целые числа а1, а2, а3. Получить целочисленный массив В[1..3, 1..3], для которого B[i,j]=ai-3aj.

10-11 класс

Ramara1970 02 дек. 2013 г., 17:32:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yttr
02 дек. 2013 г., 18:16:50 (10 лет назад)

const n=3;
var i,j:integer;
a:array[1..n] of integer;
b:array[1..n,1..n] of integer;

begin
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
begin
for j:=1 to n do
begin
b[i,j]:=a[i]-3*a[j];
write(b[i,j]:4);
end;
writeln;
end;

end.

+ 0 -
Danilka09032003
02 дек. 2013 г., 19:07:39 (10 лет назад)

Program PainNagato;
uses crt;
const n=3;
var i,j:integer;
  a:array[1..n] of integer;
  b:array[1..n,1..n] of integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  for i:=1 to n do
    begin
      write('Введите ',i,'-е число ');
      readln(a[i]);
    end;
  writeln('Результат: ');
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          b[i,j]:=a[i]-3*a[j];
          write(b[i,j]:5);
        end;
      writeln;
    end;
end.

Ответить

Другие вопросы из категории

Тема: "Построение циклических алгоритмов"

1)Для всех чисел от -5 до 60 найти и вывести их кубы.
2)Найдите сумму нечетных чисел 1 до 100.
3)Подсчитать количество всех четных чисел от -20 до 20
4)Для всех четных чисел от 10 до 78 найти и вывести значение функции y=5x^3-6x

Помогите!

Не сложно, но срочно.

Написать программу для Pascal.
Дано целое число, если оно является положительным, то прибавь к нему 5; в противном случае не изменять его. Вывести полученное число.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дано целое число k (1<=k<=180) и последовательность цифр 10111213...9899, в которой выписаны подряд подряд все двузначные числа. Определить

двузначное число, образованное парой цифр, в которую входит k-я цифра;
Примечание: величины строкового типа не использовать.

p.s объясните само задание, пожалуйста. Решение есть на яндексе.

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;



Вы находитесь на странице вопроса "Даны целые числа а1, а2, а3. Получить целочисленный массив В[1..3, 1..3], для которого B[i,j]=ai-3aj.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.