Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Турбо Паскаль. цикл for. Написать програму вычисляющая суму и среднее арифметическое нескольких чисел которые вводит пользователь.

5-9 класс

Nadi5716 15 февр. 2015 г., 9:40:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Дмитрий1599
15 февр. 2015 г., 10:14:33 (9 лет назад)

Program SumAndAvg;

Uses Crt;

var i,n:integer;

      s,c,a:real;

begin

    clrscr;

    write('Введите количество чисел: ');

    readln(n);

    writeln('Введите ',n,'  чисел' );

     s:=0; a:=0; 

    for i:=1 to n do

         begin         

            readln(c);

            s:=s+c;

         end;   

   a:=(s/n);  

 writeln('Сумма введённых чисел',s);

  writeln('Среднее арифметическое введённых чисел',a); 

  readkey; 

end. 

 

 

 

 

 

Ответить

Другие вопросы из категории

1) за какое время будет передан по каналам связи файл размером 625 Кбайт,если скорость передачи составляет 32000 бод( бит в секунду) ?

2) в командной строке задана маска имени файла в виде а*s?f.??c. Укажите какие имена файлов соответствует этой маске.
А)amesat.pc
Б)acrost.acc
В)afasit.ppc
Г) brosat.clc

Необходимо

ввести длинный текст в ячейку таблицы.
Ширину столбца увеличивать нельзя.
Ячейка справа занята. Как поступить?




помогите срочно 2 и 3 .

Читайте также

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).



Вы находитесь на странице вопроса "Турбо Паскаль. цикл for. Написать програму вычисляющая суму и среднее арифметическое нескольких чисел которые вводит пользователь.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.