Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

програмку составить нужно

5-9 класс

Pupsik445 13 янв. 2014 г., 23:34:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darkozer
14 янв. 2014 г., 2:02:02 (10 лет назад)

var
  i: integer;
  a: array[1..10] of integer;
begin 
writeln('Исходный массив:'); 
for i := 1 to 10 do 
    begin   
    a[i] := random(30, 50);
    write(a[i]:3)
    end;
writeln; 
writeln('Преобразованный массив:');  
for i := 1 to 10 do
    begin
    if a[i] > 40 then a[i] := 1
       else
        if a[i] < 40 then a[i] := 0;
    write(a[i]:3)
    end
end.

Другой вариант:
var
  i: integer;
  a: array[1..10] of integer;
begin  
writeln('Исходный массив:');  
for i := 1 to 10 do  
    begin    
    a[i] := random(30, 50);
    write(a[i],' ')
    end;
writeln;  
writeln('Преобразованный массив:');  
for i := 1 to 10 do
    begin
    if a[i] > 40 then a[i] := 1
       else
        if a[i] < 40 then a[i] := 0;
    write(a[i],' ')
    end
end.

+ 0 -
LanaBanana13
14 янв. 2014 г., 4:36:24 (10 лет назад)

На каком языке?

+ 0 -
79119
14 янв. 2014 г., 6:24:27 (10 лет назад)

паскаль

+ 0 -
Loshkarev62
14 янв. 2014 г., 7:39:53 (10 лет назад)

а зачем здесь делить на 3?

Ответить

Читайте также

Поомогите, пожайлуста. Нужно составить программу на паскале. Ежемесячная стипендия студента составляет a руб.Расходы на проживание превышают стипендию

и составляют b руб(в месяц).Рост цен ежемесячно увеличивает расходы на 3%,составьте программу расчета необходимой суммы денег,которую нужно единовременно попросить у родителей,чтобы можно было прожить 10 месяцев,используя эти деньги.

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!

Нужно составить програмку, чтоб решить пример: 39*54-84 в квадрате. Program product; var a,b,c:integer;

a:=39*54-sqr(84));

readln

end.

Напишите ошибку, ну и объясните, если не сложно)

Помогите!Очень нужно)))

В строке символов определить кол-во букв А.
Нужно составить программу на Паскале))



Вы находитесь на странице вопроса "програмку составить нужно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.