Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Здравствуйте , задача 6.2 не работает , можете помочь , и желательно с объяснением . =) Я попробовал в Pascal ABC запустить , и она выдаёт пустое

10-11 класс

окно .
function len(s: integer): byte;
var i, l: byte;
begin l := s;
while (l > 0) do
begin
l := l div 10;
inc(i);
end;
len := i;
end;
var i: integer;
begin i := 3;
repeat
i := i * 3;
until (len(i) = 6);
writeln(i);
end.

Foool 17 авг. 2014 г., 14:22:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Smirnovaarina
17 авг. 2014 г., 15:26:14 (9 лет назад)

Что сделала я, чтобы у меня запустилось:
1) поменяла тип переменной l на integer (вы же ей присваиваете s, который может быть большим)
2) поменяла цикл в функции на repeat-until (оно запустится и так, но len(0), на мой взгляд, должно равняться 1, а не 0 :) )

Ответить

Читайте также

Информатики, помогите! Не работает интернет, и вот такой крестик.

что это значит, и почему он не работает?
как мне это исправить?

СРОЧНО!Пишу прогу с процедурами, которая считает количество "особых "элементов матрицы, но в конце проги не работает writeln, в чём может быть проблема?

Вот задача.
Заданная целочисленная матрица размером NXM. Определить k-количество "особых" элементов матрицы, считая элемент "особым", если в его строке слева от него находятся элементы, меньшие его, а справа - большие.
Вот мой код.И если уж у меня все плохо,то предложите свой код программы.
program samost;
const n=5;
m=5;
type tmatr = array[1..n, 1..m] of integer;
var a:tmatr;
i,j,k:integer;
procedure PrintMatrix(var g:tmatr);
begin
var i,j,k:integer;
for i:=1 to n do
begin
for j:=1 to n do
write(g[i,j]:4);
writeln
end;
end;
procedure MakeMatrix;
begin
var i,j,k:integer;
randomize;
for i:=1 to n do
for j:=1 to n do
begin
a[i,j]:=random(10)-5;
end;
end;
begin
MakeMatrix;
writeln('matrica A: ');
PrintMatrix(a);

k:=0;
for i:=1 to n do
for j:=1 to m do
begin
if (a[i,j]<a[i+1,j])and(a[i,j]>a[i-1,j]) then inc(k)
end;
writeln('kolichestvo elementov = ',k);
end.

Очень вас прошу помочь написать программу.Написать программу-

1)с помощью генератора случайных чисел создать Н числа в диапазоне с [-50;50](длину массива Н надо ввести с клавиатуры)
2)надо вывести сделанный массив на экран
3)нужно вычислить и вывести,какое количество парных чисел
4)и вывести на экран все парные числа.
Очень вас прошу помогите,очень нужно до завтра сделать.Если можете помочь мне,пожалуйста помогите.

Можете помочь? Пожалуйста!

В концептуальную базу ОПП не входит:


1. модульность

2. иерархия

3. абстрагирование

4. инвариантность

5. инкапсуляция



Вы находитесь на странице вопроса "Здравствуйте , задача 6.2 не работает , можете помочь , и желательно с объяснением . =) Я попробовал в Pascal ABC запустить , и она выдаёт пустое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.