Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

даны два числа A и B найти произведение всех целых чисел из промежутка от A до B

10-11 класс

Songtwo 13 авг. 2016 г., 7:36:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leonov1981
13 авг. 2016 г., 10:06:06 (7 лет назад)

P:=0;

for i:=a to b do

  for j:=a to b do

    P:=p+i*j;

 

Не забываем про спасибо :)

+ 0 -
RAFIK2004
13 авг. 2016 г., 12:59:17 (7 лет назад)

Program Zadacha;
var
    a, b: integer;
    min, max: integer;
    p: integer;
    i: integer;
Begin
    Write('Enter a, b ');
    ReadLn(a, b);
    
    if (a < b) then
    begin
        min := a;
        max := b;
    end
    else
    begin
        min := b;
        max := a;
    end;
    
    p := 1;
    for i := min to max do
        p := p * i;
        
    WriteLn(p);    
            
    ReadLn;
End.

Ответить

Другие вопросы из категории

ученик задумал число от -10 до 10 какова вероятность того,что квадрат этого числа больше 25?меньше 10?равен 49?

за контрольную работу в классе из 30 человек учитель поставил 7 пятёрок,9 четверок,8 троек и 6 двоек.Сколько битов информации несёт сообщение "Ваня не получил двойку"?

Для

кодирования букв О, К, М, Л решили
использовать двоичное представление чисел 0,
1, 2 и 3 соответственно (с сохранением одного незначащего нуля в случае
одноразрядного представления). Если закодировать последовательность букв МОЛОКО таким способом и результат
записать шестнадцатеричным кодом, то получится.?

Читайте также

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

. Даны два целых числа A и B

(A < B). Найти произведение всех целых чисел от A до B
включительно.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5



Вы находитесь на странице вопроса "даны два числа A и B найти произведение всех целых чисел из промежутка от A до B", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.