Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Информатика.Паскаль.Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P.S т.е мало того что нам

10-11 класс

нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.

OleskaZombi 16 марта 2017 г., 12:21:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krutovsky
16 марта 2017 г., 14:19:09 (7 лет назад)

var

  N, count:integer;

begin

   write('N = ');

  readln(N);

  count := 0;

  while N > 0 do

  begin

    if (N mod 10) mod 3 = 0 then

      count := count + 1;

    N := N div 10;

  end;

  writeln('Count = ', count);

  readln;

end.

Ответить

Другие вопросы из категории

Знаю,вопрос не для этого сайта, но мало ли кто поможет

очень прошу
обновила андроид до 5.0. Nexuc4.не работает много приложений, просто выкидывает, а т. ж. плей маркет (пишет нет соединения)что делать? ведь интернет работает и вай фай есть, т. ж. не могу прослушивать музыку (сам значок не открывается) , не работает будильник, просто на экран не выдает (не вибро, не звонка) и много других проблем

Z= 0.52*10^{-2}*C + ctg(\pi*B) W= Z*lg |AD^{2} +sinB |[/tex]

Пожалуйста, напишите на языке паскаль программу

Задание:

Определить номера строк двумерной матрицы, содержащих только положительные элементы.
Выполнить нужно в Delphi7. Оконным приложением. И чтоб стрингрид был.
Заранее спасибо!

ПРОГРАММА НЕ ПРАВИЛЬНО РАБОТАЕТ. ГДЕ ОШИБКА?procedure par(msg:string);

begin
write('Ошибка: ',msg);
halt(1);
end;
var
school,a:string;
begin
writeln('Введите пароль ');
read(a);
if a=school then write ('Вы получили доступ');
if a<>school then par('Доступ не был получен ');
end.

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

паскаль 1)

Составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем.
2)
Составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и разность прогрессии вводятся пользователем. Вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.



Вы находитесь на странице вопроса "Информатика.Паскаль.Дано натуральное число N. Составить программу, которая определяет, сколько цифр этого числа кратны трем. P.S т.е мало того что нам", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.