Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму N произвольных чисел, вводимых с клавиатуры c++

10-11 класс

Вакавакаф 23 авг. 2013 г., 15:36:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asgard941
23 авг. 2013 г., 17:50:48 (10 лет назад)

Для Microsoft Visual Studio 2012

#include <iostream>
using namespace std;
void main(){
setlocale(0,"");
int a,b=0,c,d=0;
cout<<"Введите длину посдедовательности ";cin>>c;
do {cout<<"Введите число: ";cin>>a;b=b+a; d++;} while(d!=c);
cout<<"Сумма чисел в последовательности = "<<b;
cin.get();
cin.get();
}


Для Microsoft Visual Studio 2006

#include <iostream.h>
void main(){
int a,b=0,c,d=0;
cout<<"Введите длину посдедовательности ";cin>>c;
do {cout<<"Введите число: ";cin>>a;b=b+a; d++;} while(d!=c);
cout<<"Сумма чисел в последовательности = "<<b;
}


2 вариант этой же программы

Для Microsoft Visual Studio 2012

#include <iostream>
using namespace std;
void main(){
setlocale(0,"");
int a,b=0,c;
char d;
do {cout<<"Введите число: ";cin>>a;b=b+a; cout<<"Хотите ввести еще число?(y/n)";cin>>d;} while(d!='n');
cout<<"Сумма чисел в последовательности = "<<b;
cin.get();
cin.get();
}

Для Microsoft Visual Studio 2006

#include <iostream.h>
void main(){
int a,b=0,c;
char d;
do {cout<<"Введите число: ";cin>>a;b=b+a; cout<<"Хотите ввести еще число?(y/n)";cin>>d;} while(d!='n');
cout<<"Сумма чисел в последовательности = "<<b;
}

Ответить

Читайте также

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если первое число четно, то выведите сумму этих четырех чисел.
Если второе и третье числа положительны,то выведите их среднее арифметическое.
Если выполняются одновременно два перечисленных выше условия, то выведите все четыре числа без изменения.
Иначе, выведите числа, противоположные исходным.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

паскаль написать программу Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если сумма

первых двух чисел четна, то выведите эту сумму. Если сумма третьего и четвертого чисел четна и отрицательна, то выведите все четыре числа без изменения. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих четырех чисел. Иначе, выведите суммы двух первых и двух последних чисел.



Вы находитесь на странице вопроса "Найти сумму N произвольных чисел, вводимых с клавиатуры c++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.