Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

напишите программу на языке паскаль для следуюзей задачи: для любого четырехзначного числа найти сумму первой и предпоследней цифры. Используя тип

10-11 класс

данных integer, и операции div mod

M009ax23 13 июля 2013 г., 21:52:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Verinaarina
14 июля 2013 г., 0:25:49 (10 лет назад)

var
A,S:integer;
begin
Write('Введите четырехзначное число:');
Readln(A);
S:=(A div 1000)+(A div 10) mod 10;
WriteLn(S);
Readln;
end.

Ответить

Читайте также

Напишите программу на языке Паскаль, для решения следующей задачи:

Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).
(Подсказка. Используйте тип данных integer и операции div и mod)

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Составьте

программу на языке Паскаль для следующих задач:

1. Найдите сумму всех чисел от

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.



Вы находитесь на странице вопроса "напишите программу на языке паскаль для следуюзей задачи: для любого четырехзначного числа найти сумму первой и предпоследней цифры. Используя тип", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.