Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте

10-11 класс

программу на языке Паскаль для следующих задач:

1. Найдите сумму всех чисел от

Slavinanastya 26 марта 2015 г., 16:17:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
тололошка
26 марта 2015 г., 18:49:04 (9 лет назад)

var i, a, s: integer;
begin
     readln(a);
     for i := a to 500 do
         s := s + i;
     writeln(s);
end.

2) 
var i, a, s, c, b: integer;
begin
     readln(a, b);
     for i := a to b do
     begin
         s := s + i;
         c := c + 1;
     end;
     writeln(s / c:4:2);
end.

3)
const N=10;
var i, b, s: integer;
    a: array [0..N] of integer;
begin
     readln(b);
     for i := 0 to N do a[i] := random(9000);
     for i := 0 to N do
         if (a[i] < b) then s := s + i;
     for i := 0 to N - 2 do
         if (a[i+1] = b) then writeln('(', a[i], '; ', a[i+2], ')');
     writeln(s);
end.

=)

Ответить

Другие вопросы из категории

Сумма натуральных чисел из диапазона [10100в 2сс ;27 в 8 сс] равна..

а)56 в 10 сс
б)56 в 8 сс
в)56 в 16 сс
г)56 в 32 сс

помогите пожалуйста! срочно!

Задан квадратный массив. Найти сумму элементов по периметру массива.

Читайте также

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием



Вы находитесь на странице вопроса "Составьте", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.