Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и

10-11 класс

вывести список книг, изданных после 2003 года.



2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

Gabiev98 03 июля 2014 г., 5:26:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gabidov80
03 июля 2014 г., 7:14:20 (9 лет назад)

Сделано для трёх книг, потом поменяешь в двух местах

PROGRAM prim2;
uses crt;
Type
book=record
avtor: string[20];
name:string[25];
year:integer;
end;

Var
f,i: integer;
b:array[1..3] of book;
BEGIN
clrscr;
f:=0;
{формирование записей}
for i:=1 to 3 do
Begin
write('Введите название книги: ');
readln(b[i].name);
write('Введите фамилию автора: ');
readln(b[i].avtor);
write('Введите год издания: ');
readln(b[i].year);
end;
writeln;
Writeln('Сведения о книгах (автор,название,год издания) год издания которых позже 1990');
for i:=1 to 3 do
Begin
if b[i].year>2003 then {проверка условия задачи}
Begin
f:=f+1;
Writeln(f:6,' ', b[i].avtor,' ', b[i].name,' ', b[i].year);
end;
end;
writeln('Итог: ',f);
readln;
END.

Ответить

Другие вопросы из категории

напишите в паскале пжл

Дано натуральное число. Определить какое из цифр встречается в этом числе чаще 0 или 9

Объяснить смысл следующих выражений:

1.Получить информацию.
2.Содержать много полезной информации.
3.Не содержать информации.
4.Информация к размышлению.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"



Вы находитесь на странице вопроса "1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям:автор, название, год издания. Провести сортировку и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.