Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определите значение переменных s и i после выполнения следующих операторов: а) s:=0; i:=0; for i:=0 to 5 do s:=s+1;

5-9 класс

б) s:=1;

n:=1;

for i:=2 to n do s:=s+1;

Fgjkkbyfhbz 10 дек. 2016 г., 0:15:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xstdoc
10 дек. 2016 г., 1:29:12 (7 лет назад)

а) S = 6 (цикл 6 раз будет выполнен)

 

б) S = 1 (цикл ни разу не будет выполнен)

Ответить

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Задание 1. Чему равен F(x) после выполнения следующих операторов? для x=4; 5; 3; 2; if x>=3

then if x<5 then F:=0

else F:=x*x

else F:=4+x

Чему равен R после выполнения следующих операторов?

R:= -10; 0; 5

if R<0 then R:=R*R;

if R=0 then R:=R+10;

if R>0 then R:=R-100;

Подробности от учителя:1.Определить значение переменной у после выполнения следующего фрагмента программы:

y:=1;
For i:=2 to 4 do y:=y+i;

2.Определить значение переменной у после выполнения следующего фрагмента программы:
y:=0;
For i:=-100 to 100 do
If i mod 10 =5 then y:=y+i;

3. На промежутке [a;b] (a,b -целые числа, которые вводятся с клавиатуры) определить среднее арифметическое чисел кратных 7

Помогите, пожалуйста, очень срочно. Желательно с полным решение. Заранее спасибо. 1) Определите значение целочисленных переменных a и b после выполнения

фрагмента программы: a := 3 + 8*4;
b := (a div 10) + 14;
a := (b mod 10) + 2; 2) Определите значение переменной c после выполнения следующего фрагмента программы:
a := 100
b := 30
a := a – b*3
if a > b then
c := a – b
else
c := b – a
еnd if

1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a := 3 + 8*4; b :=

(a div 10) + 14;

a := (b mod 10) + 2;

2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 1819;

b := (a div 100)*10+9;

a := (10*b–a) mod 100;

3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 42;

b := 14;

a := a div b;

b := a*b;

a := b div a;

4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:

x := 5;

y := 7;

t := x;

x := y mod x;

y := t;

5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

а :=6*12 + 3;

b :=(a div 10)+ 5;

a :=(b mod 10)+ 1;



Вы находитесь на странице вопроса "Определите значение переменных s и i после выполнения следующих операторов: а) s:=0; i:=0; for i:=0 to 5 do s:=s+1;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.