Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста, очень срочно. Желательно с полным решение. Заранее спасибо. 1) Определите значение целочисленных переменных a и b после выполнения

5-9 класс

фрагмента программы: a := 3 + 8*4;
b := (a div 10) + 14;
a := (b mod 10) + 2; 2) Определите значение переменной c после выполнения следующего фрагмента программы:
a := 100
b := 30
a := a – b*3
if a > b then
c := a – b
else
c := b – a
еnd if

Crokys41740 19 июня 2014 г., 9:44:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Skomoroh00
19 июня 2014 г., 12:27:54 (9 лет назад)

1)
a=3+8*4=35;
b=(35 div 10)+14=3+14=17
a=(17 mod 10)+2=7+2=9
2)
a=100-30*3=10
т.к. а<b (10<30) то идём по отрицательной ветви (else)
c=30-10=20
Ответ: 1) а=9; 2) с=20

Ответить

Другие вопросы из категории

№1.

Светлое табло состоит из лампочек, каждая из которых мажет находиться в двух состояниях: "включено" или "выключено". Какое наименьшее количество лампочек должно находиться на табло, чтобы с его помощью можно было передавать 15 различных сигналов?
Дано: Решение:

№2.
Для передачи секретного сообщения на английском языке использовался равномерный двоичный код: каждый символ исходного сообщения кодировался двоичной цепочкой одной и той же минимально возможной длины. Какова длина двоичного кода, если исходное сообщение состояло из 20 символов?
Дано: Решение:

Заранее спасибо!
Если можно напишите пожалуйста понятным языком ( я в информатике не понимаю)

В виде программ:

1 Заполнить массив N числами(N<=1000), введенными с клавиатуры. Вывести числа в строку в прямом и обратном порядке.
2 Ввести число. Заполнить массив цифрами числа. Вывести цифры числа в строку.
3 Заполнить массив четными числами из интервала [a, b].Вывести числа в строку в обратном порядке.

Здарова всем C:

И так, Excel 2010.
Последний столбик XFD.
Вычислить кол-во столбов в Excel 2010.

Y=

{2X(в кубе) +1 / X-5, если X<4
{3X(в квадрате) -2, если X>=4
напишите пожалуйста программу... Благодарю! и спасибо за блог схему!))

Решите,прикрепленную задачку))

Читайте также

Помогите пожалуйста,очень срочно!

Ввести три числа,вывести на экран их сумму,произведение и среднее арифметическое.

(В паскале,по такому типу:
Var
Begin
WriteLn
End)
Буду очень благодарна!

помогите пожалуйста очень надо желательно с решением

Дан фрагмент программы
var X, Y: INTEGER;
begin
X := 64; Y := 63;
X := Y - X;
Y := Y - X;
X := X + Y;
WriteLn(X: 3, Y: 3);
в результате его выполнения на экран будут выведены значения:

Создать программу в Паскале, 9 класс

Поменять местами первый элемент масива и максимальный.
Заранее Спасибо) Помогите пожалуйста) Очень срочно!!)
var a: array [1..20] of integer;



Вы находитесь на странице вопроса "Помогите, пожалуйста, очень срочно. Желательно с полным решение. Заранее спасибо. 1) Определите значение целочисленных переменных a и b после выполнения", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.