Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано четырехзначное число. Проверить, является ли оно «счастливым билетом». Примечание: счастливым билетом называется число, в котором: а) при

10-11 класс

четном количестве цифр в числе сумма цифр его левой половины равна сумме цифр его правой половины; б) при нечетном количестве цифр – то же самое, но с отбрасыванием серединной цифры. Например, рассмотрим число 1322. Его левая половина равна 13, а правая – 22, и оно является счастливым билетом (т. к. 1 + 3 = 2 + 2). Аналогично: 1735 (1 + 7 = 3 + 5), 1111 (1 + 1 = 1 + 1) и т. д.

Nikolaevaanasta 09 янв. 2017 г., 6:24:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
уана
09 янв. 2017 г., 7:15:16 (7 лет назад)

var a:array [1..4] of integer; i,n:integer;
begin
writeln('Введите номер билета');
readln(n);
for i:=1 to 4 do begin
a[i]:= n mod 10;
n:= n div 10;
end;
if a[1] + a[2] = a[3] + a[4] then writeln('Билет является счастливым') else writeln('Билет не является счастливым');
end.

Ответить

Другие вопросы из категории

При регистрации в компьютерной системе каждому пользователю выдается пароль из 8 символов и содержащий только заглавные символы нижнего ряда Латинской

раскладки клавиатуры Z, X, C, V, B, N, M. Каждый такой пароль в компьютерной программе записывается минимально возможный и одинаково целым количеством байт ( при этом используют по символьное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). Определите объем памяти ( в байтах ), отводимый этой программой для записей 25 паролей. В ответ запишите только число. Заранее спасибо.

Помогите пожалуйста

очень надо

Читайте также

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.



Вы находитесь на странице вопроса "Дано четырехзначное число. Проверить, является ли оно «счастливым билетом». Примечание: счастливым билетом называется число, в котором: а) при", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.