Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

СРОЧНО НАДО 1.Заменить первый отрицательный элемент нулем 2.Умножить все элементы, кратные трем, на третий элемент массива 3.Из

5-9 класс

элементов массива Р сформировать массив М того же размера по правилу: если номер четный , то Рi=i*Mi, если нечетный, то Рi=-Mi

Nfadeeva4567 02 окт. 2013 г., 13:55:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yablochkina04
02 окт. 2013 г., 16:21:49 (10 лет назад)

1)
 var 
a:array[1..10] of integer;
i:integer;
begin randomize;
for i:=1 to 10 do a[i]:=random(100)-40;
writeln;i:=1;
while i<=10 do begin 
if a[i]<0 then begin a[i]:=0;
i:=11;end;
inc(i);
end;
for i:=1 to 10 do write(a[i]:3);
end.
2)
var a:array[1..10] of integer;
i:integer;
begin
for i:= i to 10 do read(a[i]);

Ответить

Другие вопросы из категории

Назовите ученого, достижениями которого являются: предложение

использовать перфокарты для ввода и вывода данных, изобретение системы
предварительного переноса для ускорения расчетов, введение понятия
циклов операций и рабочих ячеек.

леголас хочет поразить из лука десять мишеней, обозначенных цифрами от 0 до 9. при этом он не хочет чтобы сумма номеров двух пораженных мишеней

составляла несчаслтивое для эльфа число 11 или более. какую по мишень леголас мог поразить последней, если первая его стрела полетела в мишень с номером 0

решение 4^2014+2^2015-8=?

Читайте также

У Пети дома есть несколько компьютеров, каждый из которых имеет в своем составе системный блок, монитор и клавиатуру. Если все системные блоки,

мониторы и клавиатуру собрать вместе, то все элементы, кроме двух, будут системными блоками, все элементы, кроме двух - клавиатурами, все элементы, кроме двух, будут мониторами
Сколько компьютеров у Пети дома? Помогите, пожалуйста, решить эту задачу.

Дан массив из 8 целочисленных элементов. Элементы вводятся с клавиатуры (все элементы

различны). Найти минимальный элемент численного массива и его порядковый номер.

Световое табло состоит из светящихся элементов, каждый из которых может гореть одним из восьми различных цветов. Сколько различных сигналов можно

передать с помощью табло, состоящего из трех таких элементов (при условии, что все элементы должны гореть) ?

1) Световое табло состоит из светящихся элементов, каждый из которых может гореть одним из трех различных цветов. Сколько различных сигналов можно

передать с помощью табло, состоящего из четырех таких элементов (при условии, что все элементы должны гореть)?



Вы находитесь на странице вопроса "СРОЧНО НАДО 1.Заменить первый отрицательный элемент нулем 2.Умножить все элементы, кратные трем, на третий элемент массива 3.Из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.